Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Iedere gebruiker eigen site
Ga naar pagina Vorige  1, 2
 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Vr Jan 06, 2006 11:46 pm    Onderwerp: Reageren met citaat

Brouwkip,

Je hebt gelijk. Dit spul werkt niet. 'k Heb er even op doorgeboomd.

Sommigen zeggen om selinux af te leggen. Ik ben daar niet zo'n voorstander van.

Probeer eens het volgende in een terminal:
ls -Z public_html
Dan zie je in de lijn iets van : user_home_t staan bij je index.html
chcon -R -h -t httpd_sys_content_t public_html
en dan ls -Z public_html
dan zie je in de lijn iets van : httpd_sys_content_t ipv user_home_t

Ik moet dit nog een te goed bekijken, maar op die manier geef je te kennen dat de contence van public_html webstuff is.
Dan kan ik gewoon localhost/~username intikken en heb ik de website.

De manpage van chcon is nogal sumier.
Terug naar boven
Profiel bekijken Stuur privébericht
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Za Jan 07, 2006 9:44 am    Onderwerp: Reageren met citaat

wge schreef:
Brouwkip,

Je hebt gelijk. Dit spul werkt niet. 'k Heb er even op doorgeboomd.

Sommigen zeggen om <a href="http://fedora-linux.nl/wiki/index.php/SELinux" target="_blank">SELinux</a> af te leggen. Ik ben daar niet zo'n voorstander van.

Probeer eens het volgende in een <a href="http://www.fedora-linux.nl/basis/#terminal">terminal</a>:
ls -Z public_html
Dan zie je in de lijn iets van : user_home_t staan bij je index.html
chcon -R -h -t httpd_sys_content_t public_html
en dan ls -Z public_html
dan zie je in de lijn iets van : httpd_sys_content_t ipv user_home_t

Ik moet dit nog een te goed bekijken, maar op die manier geef je te kennen dat de contence van public_html webstuff is.
Dan kan ik gewoon localhost/~username intikken en heb ik de website.

De manpage van chcon is nogal sumier.


Nou snap ik er helemaal niks meer van Confused
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Za Jan 07, 2006 4:08 pm    Onderwerp: Reageren met citaat

Brouwkip,
0. In de /etc/httpd/conf/httpd.conf heb je UserDir disable lijn weggenomen en de andere lijn uit commentaar gehaald.
1. Je hebt een directory public_html in je user home directory gemaakt.
2. je hebt in die public_html een index.html file gemaakt .
3. De rechten toegewezen aan je home directory
4. de rechten toegewezen aan je public_html directory
5. de rechten bijgevolg ook toegewezen aan je index.html

Dan krijg je de foutmelding : permission denied.

6. open een terminal
7. su - root
8. cd /home/brouwkip
9. chcon -R -h -t httpd_sys_content_t public_html
tik dan in je browser : http://localhost/~brouwkip
en je site staat er
Terug naar boven
Profiel bekijken Stuur privébericht
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Za Jan 07, 2006 7:57 pm    Onderwerp: Reageren met citaat

harstikke bedankt het werkt! wooohooo Very Happy

nu kan ik de public_html map niet meer in op de ftp
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Zo Jan 08, 2006 3:22 pm    Onderwerp: Reageren met citaat

Dag Brouwkip,

Heb dit ook eens bekeken van ver en tot de vaststelling gekomen dat ik het ook niet helemaal versta Confused
Huiswerk dus .

Misschien dit eens doornemen http://fedora.redhat.com/docs/selinux-apache-fc3/index.html
http://fedora.redhat.com/docs/selinux-faq-fc3/index.html#id2825658

Verder kan ik je niet meer helpen. Sorry.

Voor FC4 zie ik nog nergens iets staan dus veronderstel ik dat hetzelfde is.
Terug naar boven
Profiel bekijken Stuur privébericht
Vipergts/r



Geregistreerd op: 18 Feb 2006
Berichten: 43

BerichtGeplaatst: Do Apr 13, 2006 12:42 am    Onderwerp: Reageren met citaat

wge schreef:
Brouwkip,
0. In de /etc/httpd/conf/httpd.conf heb je UserDir disable lijn weggenomen en de andere lijn uit commentaar gehaald.
1. Je hebt een directory public_html in je user home directory gemaakt.
2. je hebt in die public_html een index.html file gemaakt .
3. De rechten toegewezen aan je home directory
4. de rechten toegewezen aan je public_html directory
5. de rechten bijgevolg ook toegewezen aan je index.html

Dan krijg je de foutmelding : permission denied.

6. open een <a href="http://www.fedora-linux.nl/basis/#terminal">terminal</a>
7. su - <a href="http://www.fedora-linux.nl/basis/#root">root</a>
8. cd /home/brouwkip
9. chcon -R -h -t httpd_sys_content_t public_html
tik dan in je browser : http://localhost/~brouwkip
en je site staat er


Dit werkt voor mij niet. Als ik dus http://localhost/usernaam intik, krijg ik error 404 file not found. Hij blijft naar /var/html/www gaan.
Terug naar boven
Profiel bekijken Stuur privébericht
Steef



Geregistreerd op: 13 Feb 2006
Berichten: 5

BerichtGeplaatst: Di Jul 25, 2006 12:46 pm    Onderwerp: Reageren met citaat

Hallo,

ik heb dit probleem nu ook opgelost met de hulp van Wge. Alleen als ik nu steeds een nieuwe map aanmaak in de public_html directory, of een bestand. Moet ik daarvan steeds de rechten instellen omdat deze standaard op 600 staan.

Is hier ook een oplossing voor?

Alvast bedankt,
Stefan
Terug naar boven
Profiel bekijken Stuur privébericht
Steef



Geregistreerd op: 13 Feb 2006
Berichten: 5

BerichtGeplaatst: Zo Jul 30, 2006 2:02 pm    Onderwerp: Reageren met citaat

Iemand? Embarassed
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Ma Jul 31, 2006 9:08 am    Onderwerp: Reageren met citaat

Steef schreef:
Iemand? Embarassed

Verander je de rechten wel als "root"-zijnde?
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
VaaG



Geregistreerd op: 20 Mei 2005
Berichten: 16
Woonplaats: Rotterdam

BerichtGeplaatst: Ma Jul 31, 2006 3:37 pm    Onderwerp: Reageren met citaat

ik heb mijn httpd.conf als volgt:

voor server name heb ik:
Code:
ServerName me.eigen.ip.adres


voor userdir:
Code:
<IfModule>
    #
    # UserDir is disabled by default since it can confirm the presence
    # of a username on the system (depending on home directory
    # permissions).
    #
    #UserDir disable

    #
    # To enable requests to /~user/ to serve the user's public_html
    # directory, remove the "UserDir disable" line above, and uncomment
    # the following line instead:
    #
    UserDir public_html

</IfModule>


voor virtual hosts:
Code:
### Section 3: Virtual Hosts
#
# VirtualHost: If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost me.eigen.ip.adres
#
# NOTE: NameVirtualHost cannot be used without a port specifier
# (e.g. :80) if mod_ssl is being used, due to the nature of the
# SSL protocol.
#

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
#<VirtualHost>
#    ServerAdmin webmaster@dummy-host.example.com
#    DocumentRoot /www/docs/dummy-host.example.com
#    ServerName dummy-host.example.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>

<VirtualHost>
    DocumentRoot "/www/domein1/public_html"
    ServerName domein1
    <Directory>
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>

<VirtualHost>
    DocumentRoot "/www/domein2/public_html"
    ServerName domein2
    <Directory>
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>


als ik nu naar www.domeinnaam1.nl of 2.nl ga en er is nog geen index.html of php bestand krijg ik de standaard noindex.html te zien.

Maar als ik naar http://me.eigen.ip.adres/~domein1 ga en er is geen index.html of php bestand dan krijg ik een "The requested URL /~domein1 was not found on this server." plaats ik hier wel een index.html of php bestand dan kan die deze map wel benaderen via ~domein1.

Ik heb geen rechten etc moeten verlenen via chcon -R -h -t etc etc gewoon een user aan gemaakt de virtual host aan httpd.conf toegevoegd met daarbij de lokatie naar public_html httpd restart en gaan

btw de virtual host ziet er zo uit maar de code tags laten iets weg Confused
/www/domein1/public_html in de <Directory> tags staat tussen ""
<VirtualHost>
DocumentRoot "/www/domein1/public_html"
ServerName domein1
<Directory>
allow from all
Options +Indexes +ExecCGI
</Directory>
</VirtualHost>
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken MSN Messenger
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Ga naar pagina Vorige  1, 2
Pagina 2 van 2

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.