Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Iedere gebruiker eigen site
Ga naar pagina 1, 2  Volgende
 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Do Dec 22, 2005 4:06 pm    Onderwerp: Iedere gebruiker eigen site Reageren met citaat

Hallo,
Ik heb de tut Iedere user een eigen site gevolgd. Het klopt bij mij nu mijn user hebben geen Public_html map in hun home. Ik heb er eentje aangemaakt maar dan is ie forbidden.
Terug naar boven
Profiel bekijken Stuur privébericht
Worado



Geregistreerd op: 13 Feb 2005
Berichten: 501
Woonplaats: Goes

BerichtGeplaatst: Do Dec 22, 2005 4:13 pm    Onderwerp: Reageren met citaat

Ja... en nu in duidelijk Nederlands graag. Scheelt veel mensen nadenkwerk Razz
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Do Dec 22, 2005 4:23 pm    Onderwerp: Reageren met citaat

Worado schreef:
Ja... en nu in duidelijk Nederlands graag. Scheelt veel mensen nadenkwerk Razz


/msntaall Razz (sorry)

Ik heb een tut gevolgd :http://www.fedora-linux.nl/wiki/index.php/LAMP-server_opzetten

Ik heb het kleine deel ervan gedaan:

Citaat:
Alle gebruikers een eigen site

In je thuismap zit een map met de naam public_html. Hier kunnen alle gebruikers een eigen site in zetten. Het adres is dan http://localhost/~gebruikersnaam, of wanneer je site voor een of meerdere andere computers bereikbaar is (of voor het internet) http://adres.naar.je.server/~gebruikersnaam

Deze functie staat standaard uit, maar je kunt hem zo inschakelen:

vi /etc/httpd/conf/httpd.conf

Zoek naar <IfModule mod_userdir.c> (kan je doen door een slash (/) te typen en dan te typen waar je naar zoekt) Zet een hekje voor de volgende regel:

UserDir disable

En haal het hekje voor de volgende regel weg:

#UserDir public_html

Nu moet je nog Apache herstarten

service httpd restart

En nu heeft iedere gebruiker een eigen site!


maar ik heb geen public_html map in mijn homedirectory
Terug naar boven
Profiel bekijken Stuur privébericht
Thijs
Administrator


Geregistreerd op: 10 Feb 2005
Berichten: 1173
Woonplaats: Hengelo G.

BerichtGeplaatst: Do Dec 22, 2005 4:51 pm    Onderwerp: Reageren met citaat

Het kan zijn dat je die nog moet maken. Vanuit de terminal met "mkdir public_html".
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken MSN Messenger
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Do Dec 22, 2005 5:12 pm    Onderwerp: Reageren met citaat

Thijs schreef:
Het kan zijn dat je die nog moet maken. Vanuit de <a href="http://www.fedora-linux.nl/basis/#terminal">terminal</a> met "mkdir public_html".


forbidden!
index.html staat er gewoon in maar ik krijg een forbidden
Terug naar boven
Profiel bekijken Stuur privébericht
Thijs
Administrator


Geregistreerd op: 10 Feb 2005
Berichten: 1173
Woonplaats: Hengelo G.

BerichtGeplaatst: Do Dec 22, 2005 5:31 pm    Onderwerp: Reageren met citaat

Heb je het bestand aangemaakt met de goede rechten ?
Bijvoorbeeld:
Als je in de map /home/thijs/public_html/ het bestand index.html wilt zetten, dan moet je dat doen als je ingelogd bent als gebruiker thijs.
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken MSN Messenger
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Do Dec 22, 2005 5:47 pm    Onderwerp: Reageren met citaat

Thijs schreef:
Heb je het bestand aangemaakt met de goede rechten ?
Bijvoorbeeld:
Als je in de map /home/thijs/public_html/ het bestand index.html wilt zetten, dan moet je dat doen als je ingelogd bent als gebruiker thijs.


ok, ik heb het opnieuw gedaan maar ik blijf het probleem houden
Terug naar boven
Profiel bekijken Stuur privébericht
Thijs
Administrator


Geregistreerd op: 10 Feb 2005
Berichten: 1173
Woonplaats: Hengelo G.

BerichtGeplaatst: Do Dec 22, 2005 5:52 pm    Onderwerp: Reageren met citaat

Is de server herstart nadat de instellingen zijn veranderd?
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken MSN Messenger
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Do Dec 22, 2005 6:10 pm    Onderwerp: Reageren met citaat

Thijs schreef:
Is de server herstart nadat de instellingen zijn veranderd?


ik heb dat gedaan maakt niks uit Forbidden!
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Vr Dec 23, 2005 1:34 am    Onderwerp: Reageren met citaat

Brouwkip,

Met welke user is apache opgestart ?
ps -ef | grep apache geeft normaliter iets van dit :
root 5929 1 1 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5930 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5931 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5932 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5933 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5934 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5935 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5936 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start
nobody 5937 5929 0 01:34 ? 00:00:00 /usr/sbin/httpd -k start


met nobody of www of apache

Dan lijkt het mij het best dat je nobody:nobody (of 1 van die andere) rechten geeft aan die directory.

chown nobody:nobody /home/myuser/public_html

eens een apachectl graceful doen en normaliter zou het moeten werken.

indien nog een fout : wat vertelt /var/log/httpd/access_log en /var/log/httpd/error_log ?
Terug naar boven
Profiel bekijken Stuur privébericht
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Vr Dec 23, 2005 12:17 pm    Onderwerp: Reageren met citaat

Citaat:
[Fri Dec 23 12:24:16 2005] [notice] core dump file size limit raised to 4294967295 bytes
[Fri Dec 23 12:24:17 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Dec 23 12:24:17 2005] [notice] Digest: generating secret for digest authentication ...
[Fri Dec 23 12:24:17 2005] [notice] Digest: done
[Fri Dec 23 12:24:17 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Fri Dec 23 12:24:17 2005] [notice] LDAP: SSL support unavailable
[Fri Dec 23 12:24:18 2005] [notice] mod_python: Creating 4 session mutexes based on 150 max processes and 0 max threads.
[Fri Dec 23 12:24:19 2005] [notice] Apache/2.0.54 (Fedora) configured -- resuming normal operations
[Fri Dec 23 12:29:25 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas denied
[Fri Dec 23 12:29:27 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:29:30 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas denied
[Fri Dec 23 12:29:30 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:30:05 2005] [warn] child process 1947 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1948 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1949 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1950 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1951 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1952 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1953 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:05 2005] [warn] child process 1954 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1947 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1948 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1949 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1950 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1951 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1952 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1953 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:06 2005] [warn] child process 1954 still did not exit, sending a SIGTERM
[Fri Dec 23 12:30:17 2005] [notice] core dump file size limit raised to 4294967295 bytes
[Fri Dec 23 12:30:19 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Dec 23 12:30:20 2005] [notice] Digest: generating secret for digest authentication ...
[Fri Dec 23 12:30:20 2005] [notice] Digest: done
[Fri Dec 23 12:30:20 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Fri Dec 23 12:30:20 2005] [notice] LDAP: SSL support unavailable
[Fri Dec 23 12:30:21 2005] [notice] mod_python: Creating 4 session mutexes based on 150 max processes and 0 max threads.
[Fri Dec 23 12:30:23 2005] [notice] Apache/2.0.54 (Fedora) configured -- resuming normal operations
[Fri Dec 23 12:30:26 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas denied
[Fri Dec 23 12:30:27 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:31:10 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas/index.php denied
[Fri Dec 23 12:31:10 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:31:34 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas/index.php denied
[Fri Dec 23 12:31:34 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:31:55 2005] [notice] Graceful restart requested, doing restart
[Fri Dec 23 12:31:55 2005] [warn] (13)Permission denied: connect to listener on [::]:443
[Fri Dec 23 12:32:04 2005] [notice] Digest: generating secret for digest authentication ...
[Fri Dec 23 12:32:04 2005] [notice] Digest: done
[Fri Dec 23 12:32:05 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Fri Dec 23 12:32:05 2005] [notice] LDAP: SSL support unavailable
[Fri Dec 23 12:32:07 2005] [notice] mod_python: Creating 4 session mutexes based on 150 max processes and 0 max threads.
[Fri Dec 23 12:32:11 2005] [notice] Apache/2.0.54 (Fedora) configured -- resuming normal operations
[Fri Dec 23 12:32:15 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas/index.php denied
[Fri Dec 23 12:32:15 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:32:17 2005] [error] [client 127.0.0.1] (13)Permission denied: access to /~thomas/index.php denied
[Fri Dec 23 12:32:18 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Fri Dec 23 12:32:24 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/thomas
[Fri Dec 23 12:32:24 2005] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico


het helpt niks
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Vr Dec 23, 2005 9:47 pm    Onderwerp: Reageren met citaat

Dag brouwkip,

Het antwoord krijg je in httpd.conf in /etc/httpd/conf/httpd.conf ofwel in <PREFIX>/conf/httpd.conf (als je zelf je build gedaan hebt)
(PREFIX is normaal dan /usr/local/apache)

#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
# The path to the end user account 'public_html' directory must be
# accessible to the webserver userid. This usually means that ~userid
# must have permissions of 711, ~userid/public_html must have permissions
# of 755, and documents contained therein must be world-readable.
# Otherwise, the client will only receive a "403 Forbidden" message.
#
# See also: http://httpd.apache.org/docs/misc/FAQ.html#forbidden
#
<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
UserDir "disable"
.....
Terug naar boven
Profiel bekijken Stuur privébericht
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Vr Jan 06, 2006 6:45 pm    Onderwerp: Reageren met citaat

wge schreef:
Dag brouwkip,

Het antwoord krijg je in httpd.conf in /etc/httpd/conf/httpd.conf ofwel in <PREFIX>/conf/httpd.conf (als je zelf je build gedaan hebt)
(PREFIX is normaal dan /usr/local/apache)

#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
# The path to the end user account 'public_html' directory must be
# accessible to the webserver userid. This usually means that ~userid
# must have permissions of 711, ~userid/public_html must have permissions
# of 755, and documents contained therein must be world-readable.
# Otherwise, the client will only receive a "403 Forbidden" message.
#

# See also: http://httpd.apache.org/docs/misc/FAQ.html#forbidden
#
<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
UserDir "disable"
.....


wat moet ik nu doen dan?
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Vr Jan 06, 2006 7:18 pm    Onderwerp: Reageren met citaat

Sorry Brouwkip, mijn fout.

Vervang <userdir> door je loginnaam
(bij elk commando in de volgende lijst krijg je niks terug van het systeem, behalve een eventuele directory not found)

open een terminal
su - root
(vul een paswoord in)
cd /home
chmod 711 <userdir>
cd <userdir>
chmod 755 public_html
cd public_html
chmod -R 755 *

Deze instellingen kunnen bijvoorbeeld mbv konqueror ook op een grafische manier ingesteld worden.
Terug naar boven
Profiel bekijken Stuur privébericht
brouwkip



Geregistreerd op: 23 Nov 2005
Berichten: 19

BerichtGeplaatst: Vr Jan 06, 2006 7:37 pm    Onderwerp: Reageren met citaat

wge schreef:
Sorry Brouwkip, mijn fout.

Vervang <userdir> door je loginnaam
(bij elk commando in de volgende lijst krijg je niks terug van het systeem, behalve een eventuele directory not found)

open een <a href="http://www.fedora-linux.nl/basis/#terminal">terminal</a>
su - <a href="http://www.fedora-linux.nl/basis/#root">root</a>
(vul een paswoord in)
cd /home
chmod 711 <userdir>
cd <userdir>
chmod 755 public_html
cd public_html
chmod -R 755 *

Deze instellingen kunnen bijvoorbeeld mbv konqueror ook op een grafische manier ingesteld worden.


werkt niet Smile
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Ga naar pagina 1, 2  Volgende
Pagina 1 van 2

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.