Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Externe Hdd alleen onder root te lezen
Ga naar pagina 1, 2  Volgende
 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Hardware
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Vr Aug 22, 2008 9:58 am    Onderwerp: Externe Hdd alleen onder root te lezen Reageren met citaat

Bij het aansluiten van een externe Hdd (ntfs) kan ik als user niet op deze partitie kijken.
Als root gaat dit wel. Echter bij het veranderen van de rechten mbv chmod of chown wordt aangegeven dat het een alleen lezen bestandssysteem is.

Dit klopt ook wel voor de root, maar als user kan ik hem dus niet lezen. Ik ben wel zover gekomen om de rechten van de mappen te wijzigen, maar van de bestanden lukt dit dus niet.

Tevens maakt hij bij het opnieuw aansluiten van de schijf telkens een nieuwe map aan onder /media eerst was dit B07037 vervolgens B070371 etc. Dus toen ik de map rechten had verandert moest dit weer opnieuw na het opnieuw aansluiten.

Tips??

JDL
Terug naar boven
Profiel bekijken Stuur privébericht
Franktwh



Geregistreerd op: 17 Jan 2007
Berichten: 80
Woonplaats: Wijhe

BerichtGeplaatst: Vr Aug 22, 2008 2:26 pm    Onderwerp: Reageren met citaat

ik heb een soort gelijk probleem. Als root kan ik de scanner van mijn printer gebruiken via xsane. Als "gewone" gebruiker krijg ik de melding: geen apparaten aanwezig.

Als je de handleiding van `mount` bekijkt zie je dat het mogelijk is om gebruikers ook lees- en schrijfbevoegdheid te geven. Ik weet alleen niet hoe dat gaat met externe apparaten. /dev/sr1 bestaat bij mij alleen als ik mijn externe dvd-schrijver aansluit en aanzet. Ik neem aan dat er ergens vastgelegd is hoe linux dat moet doen ( via een soort mount opdracht). Maar waar en hoe. Ik weet het niet en kan er ook nergens iets over vinden. Maar misschein dat iemand anders of jij zelf hier een helder moment van krijgt. Laat me het dan even weten.
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Vr Aug 22, 2008 3:48 pm    Onderwerp: Reageren met citaat

Kijk eens in /dev/disk of er een entry in een van de directories staat die uniek is voor de disk in kwestie. Iets als:
Code:
/dev/disk/by-id/usb-_USB_DISK_2.0_07831133005D-0:0
/dev/disk/by-id/usb-_USB_DISK_2.0_07831133005D-0:0-part1

Je kunt die dan in /etc/fstab toevoegen:
Code:
/dev/disk/by-id/usb-_USB_DISK_2.0_07831133005D-0:0-part1 /mnt/mydisk auto defaults,noauto.user 0 0

Je zou dan, na het insteken van de disk, deze als gewone user moeten kunnen mounten met
Code:
mount /mnt/mydisk

Let op: het mount point /mnt/mydisk moet je eerst aanmaken.
Je kunt ook een udev-rule aanmaken, maar dat is tricky als je het nog nooit hebt gedaan...


Laatst aangepast door sciurius op Vr Aug 22, 2008 8:58 pm; in totaal 1 keer bewerkt
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Vr Aug 22, 2008 4:51 pm    Onderwerp: Reageren met citaat

Wat betreft die scanner: die moet je niet mounten of iets dat daar op lijkt. Welk merk heb je? Lees eens: http://www.fedora-linux.nl/forum/viewtopic.php?t=3515&highlight=scanner+udev
Terug naar boven
Profiel bekijken Stuur privébericht
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Ma Aug 25, 2008 8:19 am    Onderwerp: Reageren met citaat

Bedankt voor de reactie.

Sciurius, ik heb je adviezen opgevolgd, maar het werkt vooralsnog niet.

Mijn fstab ziet er als volgt uit:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hda1 /mnt/win_c ntfs ro,defaults,umask=0222 0 0
/dev/hda2 /mnt/win_d ntfs ro,defaults,umask=0222 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,utf8,managed 0 0
/dev/hdd /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0
/dev/disk/by-id/usb-WD_3200AAJ_External_574341505A30343439353839-part1 /mnt/mydisk auto defaults,noauto.user 0 0

/dev/sdd1 /media/B07037 ntfs pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0

De laatste regel wordt aangemaakt als ik de drive aansluit!
Ik heb ook geprobeert zonder de -part1 omdat die ook in de map /dev/disk/by-id/ staat. Daarnaast heb ik ook de ' auto" vervangen door "ntfs ro " zoals bij de win_c partitie, maar dat werkt ook niet.
Als ik handmatig probeer te mounten (moet als root), dan zegt hij dat hij nog bezig is of reeds gemount is.

Als ik kijk wat er reeds gemount is krijg ik de volgende lijst:
[root@bejo etc]# mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
/dev/proc on /proc type proc (rw)
/dev/sys on /sys type sysfs (rw)
/dev/devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda3 on /boot type ext3 (rw)
/dev/shm on /dev/shm type tmpfs (rw)
/dev/hda1 on /mnt/win_c type ntfs (ro,umask=0222)
/dev/hda2 on /mnt/win_d type ntfs (ro,umask=0222)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid2189) on /net type autofs (rw,fd=4,pgrp=2189,minproto=2,maxproto=4)/dev/sda1 on /media/B070372 type ntfs (rw,nosuid,nodev,_netdev,fscontext=system_u:object_r:removable_t,user=jdl)
/dev/sdb1 on /media/B070373 type ntfs (rw,nosuid,nodev,_netdev,fscontext=system_u:object_r:removable_t,user=jdl)
/dev/sdc1 on /media/B070371 type ntfs (rw,nosuid,nodev,_netdev,fscontext=system_u:object_r:removable_t,user=jdl)
/dev/sdd1 on /media/B07037 type ntfs (rw,nosuid,nodev,_netdev,fscontext=system_u:object_r:removable_t,user=jdl)

Opvallend is dan dat de schijf reeds 3x in de lijst staat B07037, B070371 en B070373
en dat mydisk niet in de lijst staat! Dus wel meermalen gemount maar niet in te zien als user?

Ik hoop dat je nog iets weet wat te doen?
JDL
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Ma Aug 25, 2008 12:10 pm    Onderwerp: Reageren met citaat

JDL schreef:
... /mnt/mydisk auto defaults,noauto.user 0 0

Zou het het puntje tussen noauto en auto kunnen zijn (moet een komma zijn)?
Verder krijg je natuurlijk ruzie met hal, die de disk automatisch probeert de mounten. Dat kun je afzetten in
Preferences > Hardware > Removeable drives ...
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Franktwh



Geregistreerd op: 17 Jan 2007
Berichten: 80
Woonplaats: Wijhe

BerichtGeplaatst: Ma Aug 25, 2008 4:10 pm    Onderwerp: Reageren met citaat

@nickname55: Hé bedankt voor de tip. Ik moet eerlijk bekennen dat ik die draad zelf had gestart. Het werkt nu allemaal weer prima.
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Di Aug 26, 2008 8:21 am    Onderwerp: Reageren met citaat

Ik heb het puntje vervangen en de autodetectie uitgezet

Ik zie mydisk wel in het bestandssysteem staan maar krijg daar de volgende melding

mount: I could not determine the filesystem type, and none was specified

Ipv de auto, defaults heb ik ntfs, defaults geprobeerd, maar dat leek ook niet te werken, terwijl bij autodetectie de schijf als ntfs getypeerd wordt. Wellicht moet ik het op een ander positie aangeven?


JDL
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Di Aug 26, 2008 10:23 am    Onderwerp: Reageren met citaat

Nee, ntfs moet in plaats van de 'losse' auto.
Code:
... /mnt/mydisk ntfs defaults,noauto.user 0 0

Maar ik zou denken dat hij dat zelf kan detecteren. Je mount toch wel de juiste partitie? Die met -part1 erachter?
Post anders even de uitkomst van
Code:
/sbin/fdisk -l /dev/disk/by-id/usb-_USB_DISK_2.0_07831133005D-0:0
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Di Aug 26, 2008 10:54 am    Onderwerp: Reageren met citaat

het mounten van mydisk gaat nu goed, maar ik heb nog steeds geen rechten om op de schijf te kijken. Dus hetzelfde als toen hij zelf de schijf aansloot!

moet de user dan nog gespecificeerd worden o.i.d.?
Terug naar boven
Profiel bekijken Stuur privébericht
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Di Aug 26, 2008 11:07 am    Onderwerp: Reageren met citaat

Ter info
Met behulp van chmod of chown krijg ik onderstaan de meldingen, dat werkt dus ook niet.

[jdl@bejo mnt]$ ls
mydisk win_c win_d
[jdl@bejo mnt]$ ls -l
totaal 24
dr-x------ 1 root root 4096 jul 9 14:26 mydisk
dr-xr-xr-x 1 root root 8192 jul 24 10:29 win_c
dr-xr-xr-x 1 root root 12288 jul 24 10:32 win_d
[jdl@bejo mnt]$ su
Password:
[root@bejo mnt]# chmod 555 /mnt/mydisk
chmod: changing permissions of `/mnt/mydisk': Alleen-lezen bestandssysteem
[root@bejo mnt]# chown -R jdl /mnt/mydisk
chown: changing ownership of `/mnt/mydisk': Alleen-lezen bestandssysteem
chown: cannot access `/mnt/mydisk/070422_FC4312': Invoer/uitvoer fout
chown: cannot access `/mnt/mydisk/071112_fc12747': Invoer/uitvoer fout
chown: cannot access `/mnt/mydisk/assemblies': Invoer/uitvoer fout
chown: cannot access `/mnt/mydisk/Backuo Mirelle D': Invoer/uitvoer fout
chown: cannot access `/mnt/mydisk/Backup Dorien D': Invoer/uitvoer fout
chown: cannot access `/mnt/mydisk/docs': Invoer/uitvoer fout
chown: cannot access `/mnt/mydisk/RECYCLER': Invoer/uitvoer fout
chown: changing ownership of `/mnt/mydisk/System Volume Information': Alleen-lezen bestandssysteem
[root@bejo mnt]#

Vervolg ?????
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Di Aug 26, 2008 12:10 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Code:
... /mnt/mydisk ntfs defaults,noauto.user 0 0
moet daar niet een komma staan ipv een punt?

Vervolgens als ik doe man mount lees ik onder andere:
Citaat:
uid=value, gid=value and umask=value
Set the file permission on the filesystem. The umask value is
given in octal. By default, the files are owned by root and not
readable by somebody else.
Dus probeer eens met opties
Code:
defaults,noauto,user,uid=500,gid=500,umask=0022
Deze umask zorg er voor dat alleen jij kan lezen,schrijven en uitvoeren. Groep en others kunnen alleen lezen en uitvoeren en niet schrijven(2=schrijven, zie man chmod, umask is soort van omgedraaide chmod, bij umask betekend een 0 dus dat je alles mag, bij chmod mag je dan niets. Bij umask 7 mag je niets, bij chmod 7 alles. De eerste nul staat er omdat hij een octaal nummer verwacht, maar als je hem weg laat werkt het ook volgens mij. Google anders eens op "umask octal 0022"). Hierbij ga ik er vanuit dat je groepid en userid 500 is.

Ik draai Fedora 9 en bij mij word een ext disk automatisch gemound. Ik krijg gelijk venstertje met inhoud van de disk voor me neus op scherm. Ik heb zelf geen ext harde schijf, daarom ff die van mn zus geprobeert, ze heeft er een hele rij Crime Scene Investigation afleveringen opstaan, die uiteraard prima te bekijken zijn met Mplayer, full screen, uitstekende kwalteit Smile
Terug naar boven
Profiel bekijken Stuur privébericht
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Di Aug 26, 2008 12:34 pm    Onderwerp: Reageren met citaat

Je aannames zijn correct. Maar ook deze veranderingen hebben geen gevolg. Nogmaals ter info Nickname55, bij mij werd de drive ook automatisch geladen zoals waarschijnlijk de drive van je zus, maar ik kan hem dus alleen als root inzien.

Ik vind het ook heel apart dat er in mijn etc/fstab toch weer een regel (laatste regel) verschijnt alsof hij automatisch de drive heeft geladen!
Zie hieronder:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hda1 /mnt/win_c ntfs ro,defaults,umask=0222 0 0
/dev/hda2 /mnt/win_d ntfs ro,defaults,umask=0222 0 0
/dev/disk/by-id/usb-WD_3200AAJ_External_574341505A30343439353839-part1 /mnt/mydisk auto defaults,noauto,user, uid=500, gid=500, umask=0222 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,utf8,managed 0 0
/dev/hdd /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0
/dev/sdc1 /media/B070371 ntfs pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0

Nieuwe tips of verbeteringen?
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Di Aug 26, 2008 2:15 pm    Onderwerp: Reageren met citaat

Nickname55 schreef:
Code:
defaults,noauto,user,uid=500,gid=500,umask=0022

Dat is juist de functie van de 'user' in de mount opties.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
JDL



Geregistreerd op: 30 Aug 2005
Berichten: 35

BerichtGeplaatst: Di Aug 26, 2008 4:00 pm    Onderwerp: Reageren met citaat

En nu?
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Hardware Tijden zijn in GMT + 1 uur
Ga naar pagina 1, 2  Volgende
Pagina 1 van 2

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.