Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

apache en active directory

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
amco



Geregistreerd op: 15 Nov 2007
Berichten: 24

BerichtGeplaatst: Do Mrt 13, 2008 9:57 am    Onderwerp: apache en active directory Reageren met citaat

Hey, ik heb aapche geinstalleerd op centos5.0, en nu wil een connectie maken met active directory met active directory door de mod_authz_ldap module voor apache te gebruiken. In elke tutorials die ik vind is de configuratie hiervoor opgeslagen in /etc/httpd/conf.d/mod_authz_ldap.conf en in mijn /etc/httpd/conf.d/ folder zit enkel een readme en een welcome file.

In httpd.conf file wordt mod_authnz_ldap geladen, en mod_autnz_ldap.so zit in de modules folder.

Hoe zet ik mijn mod_authnz_ldap op om met active directory te connecteren. Of als je een andere manier weet om dit te doen. Wat de uiteindelijke bedoeling is, dat al mijn gebruikers van active directory een directory hebben zoals /home/username1 /home/username2 maar sommige users hebben een andere folder zoals /documents/username3 en als ik dan bv naar http://localhost/username2 surf dan zou er een popup moeten komen waar ik moet inloggen met active directory credentials als de login goed is krijg je een dir listing anders niet.
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Vr Mrt 14, 2008 11:16 pm    Onderwerp: Reageren met citaat

Misschien pakketje mod_authz_ldap installeren? Is dat pakketje ge´nstalleerd?
Code:
[gebruiker@server1 ~]$ yum list mod_auth*
Available Packages
mod_auth_kerb.i386                       5.3-3                  fedora         
mod_auth_mysql.i386                      1:3.0.0-3.1            fedora         
mod_auth_ntlm_winbind.i386               0.0.0-0.5.20070129svn7 updates         
mod_auth_pam.i386                        1.1.1-4.fc7            fedora         
mod_auth_pgsql.i386                      2.0.3-3                fedora         
mod_auth_shadow.i386                     2.2-3.fc7              fedora         
mod_authz_ldap.i386                      0.26-7.1               fedora         
[gebruiker@server1 ~]$
Terug naar boven
Profiel bekijken Stuur privébericht
amco



Geregistreerd op: 15 Nov 2007
Berichten: 24

BerichtGeplaatst: Za Mrt 15, 2008 3:59 pm    Onderwerp: Reageren met citaat

yep dat is geinstalleerd, kheb ook mod_auth_ldap en mod_auth_kerb geinstalleerd. Maar geen enkele werkt. Hier is mijn kerberos installatie

Hey i am trying to authenticate my apache to active directory true kerberos. But i keep getting this error in my apache logs:
krb5_get_init_creds_password() failed: Cannot find KDC for requested realm

however everything seems to be awright in my opinion can someone take a look.

httpd.conf looks like this
--------------------------
<Directory>
Options FollowSymLinks
AllowOverride None
AuthType Kerberos
AuthName "Kerberos Login"
KrbMethodNegotiate On
KrbMethodK5Passwd On
KrbAuthRealms SERVER.EXAMPLE.COM
Krb5KeyTab /etc/temp/auth_kerb.keytab
require valid-user
</Directory>

/etc/temp/auth_kerb.keytab looks like this
---------------------------
HTTP/SERVER.EXAMPLE.COM@EXAMPLE.COM



krb5.conf looks like this
--------------------------
[libdefaults]
ticket_lifetime = 24000
default_realm = EXAMPLE.COM
dns_lookup_realm = false
dns_lookup_kdc = false

[realms]
EXAMPLE.COM = {
kdc = SERVER.EXAMPLE.COM:88
}

[domain_realm]
.example.com = EXAMPLE.COM
example.com = EXAMPLE.COM

[appdefaults]
pam = {
debug = false
ticket_lifetime = 36000
renew_lifetime = 36000
forwardable = true
krb4_convert = false
}

____________________________________
Then i try localhost/vanessa a popup appears where i need to type in credentials from active directory, i pass them in correctly. and then it pops up again and again and again and again. Then i viewed the apache error logs==>
krb5_get_init_creds_password() failed: Cannot find KDC for requested realm
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Zo Mrt 16, 2008 1:44 pm    Onderwerp: Reageren met citaat

amco schreef:
yep dat is geinstalleerd, kheb ook mod_auth_ldap en mod_auth_kerb geinstalleerd. Maar geen enkele werkt. Hier is mijn kerberos installatie

default_realm = EXAMPLE.COM


Heb je zelf al iets geprobeerd te configureren of verwacht je dat voorbeeld configuratiebestanden gaan werken op jouw specifieke netwerk?
Terug naar boven
Profiel bekijken Stuur privébericht
amco



Geregistreerd op: 15 Nov 2007
Berichten: 24

BerichtGeplaatst: Zo Mrt 16, 2008 7:56 pm    Onderwerp: Reageren met citaat

ja ik draai alles momenteel in een testomgeving. En de domein controller noemt effectief example.com

Wink
Terug naar boven
Profiel bekijken Stuur privébericht
amco



Geregistreerd op: 15 Nov 2007
Berichten: 24

BerichtGeplaatst: Ma Mrt 17, 2008 3:32 pm    Onderwerp: Reageren met citaat

Ik probeeer http://localhost/vanessa
dan geef ik mijn active directory credentials in ==> authorization denied
in mijn apache error logs staat wel het volgende==> Directory index forbidden bij Options directive: /home/vanessa/

??
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.