Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Videoprobleem met Fedora 8

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Za Dec 22, 2007 10:55 pm    Onderwerp: Videoprobleem met Fedora 8 Reageren met citaat

Op mijn Acer Travelmate 4001WLMi http://johan.vromans.org/articles/TM4001WLMi/index.html krijg ik na upgrade naar Fedora 8 de grafische mode niet goed aan de praat.
Na inloggen als root geef ik "startx" in. Alles wordt keurig opgestart, maar het keyboard en muiskliks werken niet. Muisbeweging wel, hoewel die soms na korte of langere tijd ook stopt.
Ik kan via het netwerk in de laptop komen, en alles lijkt normaal. Voor zover ik kan nagaan hangt alleen de window manager (compiz). Een harde hang, want het is niet te killen en een reboot is nodig.
Ook als ik opstart met "xinit" (dus alleen X met een term window) gaat het soms even goed, en dan hangt het weer. De hoofdverdachte lijkt dus de X server. In de X server logfile staan echter geen onrustbarende mededelingen.
Iemand enig idee? Of tips om meer inzicht te krijgen in wat er gebeurt?
T/m Fedora Core 6 werkt alles naar behoren.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Za Dec 22, 2007 11:09 pm    Onderwerp: Reageren met citaat

Welke videokaart zit erin? En welke driver word er gebruikt? Misschien werkt het met vesa driver beter.
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Dec 23, 2007 9:46 pm    Onderwerp: Reageren met citaat

Kaart is ATI Mobility Radeon 9700. Werd in elk geval in FC6 nog prima gesupport (zij het zonder accell graphics) door de radeon driver. Voor de accell graphics moest ik de proprietary ATI driver gebruiken.
Ik had gehoopt het in F8 zonder die driver te kunnen, maar helaas...
Met de vesa driver inderdaad geen hang, maar die is niet leuk.
Ik heb nu dus maar weer de proprietary ATI driver geïnstalleerd en die lijkt het allemaal wel goed te doen. Fijn, maar tegelijk jammer...
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Ma Dec 24, 2007 10:52 pm    Onderwerp: Reageren met citaat

Ik gebruikte onder F7 ook de radeon driver zonder problemen. Onder F8 werktie bij mij ook niet. Maar de vesa driver wel. Maakt opzich niets uit, met de vesa driver onder F8 heb je hetzelfde als met de radeon driver onder onder F7.

Werkt de proprietary ATI driver goed?
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Ma Dec 24, 2007 11:39 pm    Onderwerp: Reageren met citaat

Nickname55 schreef:
Ik gebruikte onder F7 ook de radeon driver zonder problemen. Onder F8 werktie bij mij ook niet.

Aha!
Citaat:
Maar de vesa driver wel. Maakt opzich niets uit, met de vesa driver onder F8 heb je hetzelfde als met de radeon driver onder onder F7.
Helaas ondersteunt vesa mijn scherm (1280x800) niet goed (forceert 1024x768).
Citaat:
Werkt de proprietary ATI driver goed?
Eén maal. Maar als ik de X server afsluit en opnieuw opstart dan -- helaas, solid hang van het systeem.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Di Dec 25, 2007 8:48 am    Onderwerp: Reageren met citaat

sciurius schreef:
Eén maal. Maar als ik de X server afsluit en opnieuw opstart dan -- helaas, solid hang van het systeem.

Hmmm... ik had al her en der op het internet gelezen datie verre van stabiel is. Wat de radeon driver betreft, ik denk dat de radeon driver nu onder F8 3D wil werken. En dat zal waarschijnlijk bij een hele reeks 'normale' AGP kaarten werken. Maar bij mijn onboard chip niet. Een onboard chip, die van mij te minste, heeft geen eigen geheugen maar gebruikt geheugen van het moeder bord, het intern geheugen. Hoe veel kan ik in de BIOS nog instellen ook. Ik heb weleens gelezen dat men die onboard chips in de open source driver nog niet werkend hebben gekregen, 3D tenminste. Nu zit ik me weer af te vragen of het misschien mogelijk is om in de xorg.conf file een optie te zetten die er voor zorgt dat die radeon driver toch 2D zn werk doet... Daarvoor zou je de documentatie moeten lezen en ik weet niet waar ik die kan vinden Crying or Very sad
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Wo Dec 26, 2007 12:08 am    Onderwerp: Reageren met citaat

::grijnzzzzzzzzzzzzzzz::

Ik denk dat ik wat gevonden heb. Kzit nu onder F7. Als je in de shell in tikt:
Code:
xdriinfo options radeon

dan krijg je een soort van xml te zien van alle mogelijke opties met toelichting in diverse talen waaronder Nederlands. Bijna onderaan zie ik:
Citaat:
option name="no_rast" type="bool" default="false"
description lang="en" text="Disable 3D acceleration"/
description lang="de" text="3D-Beschleunigung abschalten"/
description lang="es" text="Desactivar aceleración 3D"/
description lang="nl" text="3D versnelling uitschakelen"/
description lang="fr" text="Désactiver l'accélération 3D"/
/option

Elke regel begint met een less-than sign en eindigt met een greater-than sign. Ik denk dat ik hier binnenkort eens wat dieper in duik. Wink

Linkje: http://dri.freedesktop.org/wiki/ConfigurationInfrastructure
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Do Dec 27, 2007 12:44 pm    Onderwerp: Reageren met citaat

Wat ik allemaal het geklooid weet ik niet meer, maar het probleem treedt nu niet meer op. De radeon driver doet goed zijn werk.
Helaas ondersteunt deze nog steeds geen accellerated graphics dus zal ik toch de proprietary driver weer moeten proberen.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Za Dec 29, 2007 9:59 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Wat ik allemaal het geklooid weet ik niet meer,
Het lijkt een interactie van de radeon driver met de ati driver. Als de ati (fglrx) kernel module is geladen dan werkt de radeon driver. Als de fglrx module niet is geladen dan treedt het eerdergeschetste probleem weer op.
UPDATE: Het probleem lijkt (zoals meestal) de DRI. Als ik Option DRI off in de xorg.conf file zet werkt de radeon driver naar behoren. Met DRI on hangt hij. Als de fglrx kernel module is geladen kan de radeon driver DRI niet opzetten, en dus werkt het ook.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Di Jan 01, 2008 6:29 pm    Onderwerp: Reageren met citaat

Ik heb de radeon driver werkend. Mn xorg.conf file ziet er nu als volgt uit:
Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
        Option      "XkbVariant" "intl"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
#       Option      "NoAccel" "true"
        Option      "DRI" "no"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Di Jan 01, 2008 8:45 pm    Onderwerp: Reageren met citaat

Ja, de "DRI no" is de beslissende faktor.
Helaas...
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Do Jan 03, 2008 12:14 am    Onderwerp: Reageren met citaat

Tja enige toelichting van mijn kant. Wat betreft documentatie zit het niet zo heel moeilijk in elkaar:
Code:
man radeon
man xorg.conf

En je krijgt wat je hebben wilt. Ik had eerst option NoAccel met true, maar das beetje teveel vant goede, werkt wel, maar scrollen in bijv. Firefox bij lange pagina's werkt beetje irritant. Met DRI op false of off of no of 0, maakt nie uit, werkt het wel prima. Maar tuurlijk geen 3D... jammer Crying or Very sad
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Do Jan 03, 2008 6:58 pm    Onderwerp: Reageren met citaat

Dankzij enkele experts op #radeon ben ik nu een stuk verder.
Het vermoeden bestaat dat de in de moderne radeon driver toegevoegde DRI de zaak om zeep helpt. Dat verklaart waarom dit in oudere releases wel werkte. Met de nieuwe DRI wordt de kaart als het ware overstuurd.
Met de optie DRI off schakel je DRI uit, en is het probleem verdwenen. Maar dan heb je geen accell graphics.
De suggestie uit #radeon was om eerst de proprietary driver te verwijderen, en de mesa-libGL opnieuw (met --force) te installeren. Dan de optiies "BusType" "PCI" te proberen, en "AGPtype" "1", "2", "4" en "8". AGPtype 2, 4 en 8 bieden geen soelaas, maar de andere settings werken wel.
Als ik de graphics performance vergelijk krijg ik de volgende waarden:
Code:
Setting                         glxgears                    stellarium
DRI off                            300                             0.3
BusType PCI                        770                            17
AGPType 1                         1840                            18
Belangrijker is dat de grafische performance voor serieuze toepassingen nu acceptabel is. Zelfs toereikend voor de compiz desktop graphics.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.