Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Na installatie Java 6, update 2,werkt Java niet
Ga naar pagina 1, 2, 3  Volgende
 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 2:14 pm    Onderwerp: Na installatie Java 6, update 2,werkt Java niet Reageren met citaat

Nadat ik Java 1.6, update 2, heb ge-installeerd blijkt dat ik bv op www.spelpunt.nl helemaal niet kan spelen omdat er zogezegd een oude Java-versie op staat.
Het vreemde van alles is dat als ik op het volgende klik: Werkplek - Voorkeuren er wel gewoon Java bij staat. Bij het installeren stond er het volgende: Browser(s):
Netscape 6.2x, Netscape 7, Mozilla 1.4+. Ik heb Mozilla Firefox 1.5.0.12. Ik denk dat er met Firefox 1.5.0.12 bedoeld wordt dat ik de Mozilla heb, of is dat niet waar? En zo niet, zal het dan echt daaraan kunnen liggen?
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Zo Aug 12, 2007 2:48 pm    Onderwerp: Reageren met citaat

Controleer in eerste instantie eens of je Java wel juist hebt geinstalleerd op de volgende site: http://www.java.com/en/download/help/testvm.xml
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 2:53 pm    Onderwerp: Reageren met citaat

Gul Dukat schreef:
Controleer in eerste instantie eens of je Java wel juist hebt geinstalleerd op de volgende site: http://www.java.com/en/download/help/testvm.xml


Heb ik gedaan, maar helaas is dat niet het geval. En toch heb ik alles goed nagekeken. Ik zal kijken waar de fout zit, want het ligt volgens mij dichtbij.
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Aug 12, 2007 5:13 pm    Onderwerp: Reageren met citaat

Heb je java enabled in de browser?
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 6:40 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Heb je java enabled in de browser?


Ik heb via Werkplek - Voorkeuren - Java - tabblad Java - Java application Runtime Settings - view - een vinkje bij enabled geplaatst, dus dat is al goed.
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Aug 12, 2007 7:45 pm    Onderwerp: Reageren met citaat

Nee, dit moet je in Firefox: Edit -> Preferences -> Content -> Vinkje bij Enable Java.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 7:58 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Nee, dit moet je in Firefox: Edit -> Preferences -> Content -> Vinkje bij Enable Java.


Dat heb ik nagezien en ook daar staat een vinkje bij.
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Aug 12, 2007 8:19 pm    Onderwerp: Reageren met citaat

Wat zegt
Code:
ls -la /usr/java
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Zo Aug 12, 2007 8:21 pm    Onderwerp: Reageren met citaat

Heb je de Java-plugins ook ingeschakeld en heb je Fedora ook zo ingesteld dat het de nieuwere versie van Java dient te gebruiken?
Beschrijf anders sta voor stap eens, hoe je Java hebt geinstalleerd.
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 8:31 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Wat zegt
Code:
ls -la /usr/java


[bertus@localhost ~]$ ls -la /usr/java
totaal 32
drwxr-xr-x 3 root root 4096 aug 12 13:54 .
drwxr-xr-x 16 root root 4096 aug 12 13:54 ..
lrwxrwxrwx 1 root root 16 aug 12 13:54 default -> /usr/java/latest
drwxr-xr-x 7 root root 4096 aug 12 13:54 jre1.6.0_02
lrwxrwxrwx 1 root root 21 aug 12 13:54 latest -> /usr/java/jre1.6.0_02
Terug naar boven
Profiel bekijken Stuur privébericht
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 8:43 pm    Onderwerp: Reageren met citaat

Gul Dukat schreef:
Heb je de Java-plugins ook ingeschakeld en heb je Fedora ook zo ingesteld dat het de nieuwere versie van Java dient te gebruiken?
Beschrijf anders sta voor stap eens, hoe je Java hebt geinstalleerd.


Waar kan ik zien of de Java-plugins zijn ingeschakeld en hoe kan ik Fedora zo instellen dat het de allernieuwste versie van Java gebruikt? Embarassed

Java heb ik als volgt ge-installeerd:

Via http://www.java.com/nl/ heb ik op Nu downloaden geklikt. Daarna heb ik het Linux RPM (zelfuitpakkend bestand)
(bestandsgrootte: 17.73 MB) gedownload. Daarna heb ik goed gekeken naar de instructies. Het viel me alleen op dat er van boven stond:

Dit artikel is van toepassing op:

* Platform(s):
Red Hat Linux, SUSE Linux, JDS
* Browser(s):
Netscape 6.2x, Netscape 7, Mozilla 1.4+
* JRE-versie(s):
1.5.0

Benieuwd waarom ze dat er zo duidelijk bij zeggen.Maar enfin. Daarna heb ik de instructies gevolgd die er stonden:

Het Linux RPM-bestand (zelfuitpakkend) installeren

Volg deze instructies:

1. Typ het volgende in het terminalvenster:
su
2. Typ het root-wachtwoord.
3. Ga naar de map waarin u JRE wilt installeren. Typ:
cd Als u de software bijvoorbeeld in de map /usr/java/ wilt installeren, typt u:
cd /usr/java

Opmerking over root-toegang: als u JRE wilt installeren op een locatie die betrekking heeft op het gehele systeem, zoals /usr/local, moet u zich aanmelden als root-gebruiker om over de vereiste bevoegdheden te beschikken. Als u niet over root-toegang beschikt, installeert u JRE in de map home of een submap waarvoor u over schrijfbevoegdheden beschikt.
4. Wijzig de bevoegdheden voor het bestand dat u hebt gedownload in overeenstemming met een uitvoerbaar bestand. Typ:
chmod a+x jre-1_5_0-linux-i586-rpm.bin
5. Start het installatieproces. Typ:
./jre-1_5_0-linux-i586-rpm.bin

Hierna wordt de licentieovereenkomst voor het binaire bestand weergegeven. Lees deze overeenkomst door. Druk op de spatiebalk om de volgende pagina weer te geven. Typ yes (ja) aan het einde om door te gaan met de installatie.

6. Met het installatiebestand wordt het bestand jre-1_5_0-linux-i586.rpm gemaakt in de huidige map.

7. Voer de opdracht RPM uit in het terminalvenster om de pakketten te installeren. Typ:
rpm -iv jre-1_5_0-linux-i586.rpm
8. JRE wordt ge´nstalleerd in de submap jre1.5.(versienummer) van de huidige map. In dit geval wordt JRE ge´nstalleerd in de map /usr/java/jre1.5.0. Controleer of de submap jre1.5.0 wordt vermeld onder de huidige map. Typ:
ls

De installatie is nu voltooid. Ga naar het gedeelte Inschakelen en configureren. Dat heb ik gedaan. De instructies hieronder heb ik opgevolgd.

Mozilla 1.4 en hoger

1. Ga naar de submap voor plug-ins in de Mozilla-installatiemap
cd <installatiemap>/plugins
2. Maak in de huidige map een symbolische koppeling naar het JRE-bestand ns7/libjavaplugin_oji.so. Typ:
ln -s <installatiemap>/plugin/i386/ns7/libjavaplugin_oji.so

Voorbeeld:
* Mozilla is ge´nstalleerd in deze map:
/usr/lib/mozilla-1.4/
* En JRE is ge´nstalleerd in deze map:
/usr/java/jre1.5.0
* In dit geval typt u de volgende opdracht in het terminalvenster om naar de map voor plug-ins voor de browser te gaan:
cd /usr/lib/mozilla-1.4/plugins
* Voer de volgende opdracht in om een symbolische koppeling naar de Java-plug-in te maken voor de Mozilla-browser.
ln -s /usr/java/jre1.5.0/plugin/i386/ns7
/libjavaplugin_oji.so .
3. Start de Mozilla-browser of start deze opnieuw als deze al wordt uitgevoerd. Als er andere Mozilla-onderdelen (bijvoorbeeld Messenger, Composer, enzovoort) worden uitgevoerd, moet u deze ook opnieuw starten.
4. Ga naar Edit > Preferences (Bewerken > Voorkeuren). Selecteer Enable Java (Java inschakelen) onder de categorie Advanced (Geavanceerd).

Natuurlijk heb ik wel, i.p.v. jre 1.5.0, de laatste versie die ik gedownload heb ingevuld.
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Zo Aug 12, 2007 9:43 pm    Onderwerp: Reageren met citaat

Wat geeft het volgende commando:
Code:

/usr/sbin/alternatives --config java

?
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 10:13 pm    Onderwerp: Reageren met citaat

Gul Dukat schreef:
Wat geeft het volgende commando:
Code:

/usr/sbin/alternatives --config java

?


Er is 1 programma die 'java' levert.

Selectie Opdracht
-----------------------------------------------
*+ 1 /usr/lib/jvm/jre-1.4.2-gcj/bin/java

<enter> om de huidige selectie te bewaren[+], of type een selectienummer:
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Ma Aug 13, 2007 8:53 am    Onderwerp: Reageren met citaat

Probeer je Java-plugin eerst eens te activeren, middels het commando:
Code:

ln -s /usr/java/jre1.6.0_01/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins

Let wel, dat je jre1.6.0_01 vervangt door de versie van Java die jij geinstalleerd hebt.
Vervolgens moet je Fedora nog even duidelijk maken, dat Fedora niet de Open source-variant gebruikt maar de versie die jij net geinstalleerd hebt, middels het commando:
Code:

/usr/sbin/alternatives --install /usr/bin/java java \
   /usr/java/jre1.6.0_01/bin/java 1601

Let op. Ook hier dien je jre1.6.0_01 en java 1601 te vervangen door de versie die jij geinstalleerd hebt.
Vervolgens moeten er dan meerdere opties worden getoond m.b.v. het commando:
Code:
/usr/sbin/alternatives --config java

Wss zoiets als dit:
Code:

  Selection    Command
-----------------------------------------------
 + 1           /usr/lib/jvm/jre-1.5.0-gcj/bin/java
*  2           /usr/java/jre1.6.0_01/bin/java

Enter to keep the current selection[+], or type selection number: 2

Selecteer dan de 2e versie. Nu zou de installatie goed moeten zijn, indien je de eerste stappen van installatie van goed doorlopen hebt. Je kunt dan controleren of alles goed is gegaan m.b.v. het commando:
Code:

java -version

Waar dan normaal gesproken, zoiets uit zo moeten komen:
Code:

java version "1.6.0_01"
Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
Java HotSpot(TM) Client VM (build 1.6.0_01-b06, mixed mode, sharing)

Nogmaals dit werkt alleen als je Java juist geinstalleerd hebt. Wat je hier doet is alleen de Java-plugins activeren en Fedora vertellen dat Fedora niet de Open Source variant dient te gebruiken. Overigens, dien je Firefox wel even te herstarten om het geheel ook nog eens te testen op: http://www.java.com/en/download/help/testvm.xml
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Ma Aug 13, 2007 9:45 am    Onderwerp: Reageren met citaat

Gul Dukat schreef:
Probeer je Java-plugin eerst eens te activeren, middels het commando:
Code:

ln -s /usr/java/jre1.6.0_01/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins

Let wel, dat je jre1.6.0_01 vervangt door de versie van Java die jij geinstalleerd hebt.
vm.xml


Als ik het commando
Code:
ln -s /usr/java/jre1.6.0_01/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins
( met mijn Java-versie jre6u2 ) ingeef, komt er hetvolgende

[bertus@localhost ~]$ ln -s /usr/java/jre6u2/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins
ln: bezig symbolische koppeling `/usr/lib/mozilla/plugins/libjavaplugin_oji.so' naar `/usr/java/jre6u2/plugin/i386/ns7/libjavaplugin_oji.so' aan te maken: Bestand bestaat al

Begrijp ik nu goed dat de Java-plugins in orde zijn, of betekent, dat het bestand al bestaat, iets anders?
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software Tijden zijn in GMT + 1 uur
Ga naar pagina 1, 2, 3  Volgende
Pagina 1 van 3

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.