Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Flash-plugin al ge-installeerd, maar steeds updatemelding
Ga naar pagina 1, 2  Volgende
 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Za Aug 11, 2007 1:06 pm    Onderwerp: Flash-plugin al ge-installeerd, maar steeds updatemelding Reageren met citaat

Als ik de update wil installeren voor het flash-plugin pakket, staat er hetvolgende:

Fout bij bijwerken software

[('package flash-plugin-9.0.48.0-a is already installed', (2, None, OL))]

Maar waarom staat er dan dat er nog een bijgewerkte update is?
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Zo Aug 12, 2007 2:43 pm    Onderwerp: Re: Flash-plugin al ge-installeerd, maar steeds updatemeldin Reageren met citaat

Kluivertnr1 schreef:
Maar waarom staat er dan dat er nog een bijgewerkte update is?

Overigens, waar wordt dit vermeldt?
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 2:54 pm    Onderwerp: Re: Flash-plugin al ge-installeerd, maar steeds updatemeldin Reageren met citaat

Gul Dukat schreef:
Kluivertnr1 schreef:
Maar waarom staat er dan dat er nog een bijgewerkte update is?

Overigens, waar wordt dit vermeldt?


Naast de klok rechts bovenaan op mijn scherm. ( als ik met mijn pijltje op het icoontje van Pup ga staan, staat het er )
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Aug 12, 2007 5:07 pm    Onderwerp: Reageren met citaat

Het zou een mixup van verschillende repositories door elkaar kunnen zijn. Misschien help het geheel te de´nstalleren en dan opnieuw te installeren.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 7:28 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Het zou een mixup van verschillende repositories door elkaar kunnen zijn. Misschien help het geheel te de´nstalleren en dan opnieuw te installeren.


Ik heb het idd nu verwijderd. Als ik daarna bekijk of er updates zijn, staat er merkwaardigerwijs:

Op het moment zijn er voor uw systeem geen bijgewerkte pakketten beschikbaar.

We zullen denk ik nooit weten waarom mijn pc dat update bericht bleef weergeven en dat, als ik de desbetreffende package verwijder, dat de pc dan zegt dat er geen enkel bijgewerkt pakket beschikbaar is.
In ieder geval ontzettend bedankt voor je meedenken. Iedere keer steek ik weer wat meer op van Linux. Wink
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Aug 12, 2007 7:44 pm    Onderwerp: Reageren met citaat

Er worden alleen updates voor ge´nstalleerde pakketten bekeken. Als een pakket niet is ge´nstalleerd dan worden er ook geen updates gezien.
Wat gebeurt er wanneer je het pakket nu opnieuw installeert? Hou ook even in de gaten van welke repository het pakket wordt ge´nstalleerd.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 7:56 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Er worden alleen updates voor ge´nstalleerde pakketten bekeken. Als een pakket niet is ge´nstalleerd dan worden er ook geen updates gezien.
Wat gebeurt er wanneer je het pakket nu opnieuw installeert? Hou ook even in de gaten van welke repository het pakket wordt ge´nstalleerd.


Ik wil het pakket via Yum terug installeren, maar Yum is toch een repository?
Kan het dan zijn dat Yum het weer van een andere repository haalt?
Terug naar boven
Profiel bekijken Stuur privébericht
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 8:11 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Er worden alleen updates voor ge´nstalleerde pakketten bekeken. Als een pakket niet is ge´nstalleerd dan worden er ook geen updates gezien.
Wat gebeurt er wanneer je het pakket nu opnieuw installeert? Hou ook even in de gaten van welke repository het pakket wordt ge´nstalleerd.


Dit staat er, als ik het via Yum installeer:

[root@localhost bertus]# yum install package flash-plugin-9.0.48.0-a
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
http://rpm.livna.org/fedora/6/i386/repodata/repomd.xml: [Errno 4] IOError: <urlopen>
Trying other mirror.
livna 100% |=========================| 2.1 kB 00:00
flash 100% |=========================| 1.9 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
jpackage-fedora 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:00
jpackage-generic 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 1.7 MB 00:06
extras : ################################################## 5363/5363
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package flash-plugin.i386 0:9.0.48.0-a set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
flash-plugin i386 9.0.48.0-a flash 2.5 M

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 2.5 M
Is this ok [y/N]:

Aangezien resolve oplossen betekent, zijn de afhankelijkheden opgelost. Het wordt waarschijnlijk anders bedoelt of niet?
Is het verstandig om gewoon deze flash-plugin te installeren?
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Aug 12, 2007 8:17 pm    Onderwerp: Reageren met citaat

Waarom installeer je niet gewoon met
Code:
yum install flash-plugin
Door zelf expliciete versienummers op te geven vraag je om moeilijkheden.
Verder zou je alle repos kunnen disabelen (behalve flash):
Code:
yum --disablerepo=\* --enablerepo=flash install flash-plugin
Daarmee voorkom je problemen wanneer verschillende repos hetzelfde package maar met een verschillende build of versie bieden.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Zo Aug 12, 2007 8:53 pm    Onderwerp: Reageren met citaat

sciurius schreef:
Waarom installeer je niet gewoon met
Code:
yum install flash-plugin
Door zelf expliciete versienummers op te geven vraag je om moeilijkheden.
Verder zou je alle repos kunnen disabelen (behalve flash):
Code:
yum --disablerepo=\* --enablerepo=flash install flash-plugin
Daarmee voorkom je problemen wanneer verschillende repos hetzelfde package maar met een verschillende build of versie bieden.


Hier het resultaat:

[root@localhost bertus]# yum --disablerepo=\* --enablerepo=flash install flash-plugin
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
flash 100% |=========================| 1.9 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package flash-plugin.i386 0:9.0.48.0-a set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
flash-plugin i386 9.0.48.0-a flash 2.5 M

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 2.5 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: flash-plugin ######################### [1/1]

Installed: flash-plugin.i386 0:9.0.48.0-a
Complete!
[root@localhost bertus]#

Dus nadat ik yum --disablerepo=\* --enablerepo=flash install flash-plugin en vervolgens bevestigend heb beantwoord of het ok was, weet ik ook dat ik niet meer yum install flash-plugin hoef in te voeren.
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Ma Aug 13, 2007 9:23 am    Onderwerp: Reageren met citaat

Dit ziet inderdaad uit als een correcte install. Benieuwd of je nu nog reare update meldingen krijgt.
Bottom line: keep it simple.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Ma Aug 13, 2007 10:26 am    Onderwerp: Reageren met citaat

sciurius schreef:
Dit ziet inderdaad uit als een correcte install. Benieuwd of je nu nog reare update meldingen krijgt.
Bottom line: keep it simple.


Er is opnieuw een bijgewerkte update beschikbaar en het is weer de flash-plugin update.

Als ik vervolgens op 'pas updates toe' klik, komt er opnieuw de foutmelding.
Heel vreemd.
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Ma Aug 13, 2007 10:33 am    Onderwerp: Reageren met citaat

Op zich niet erg vreemd, aangezien de laatst beschikbare versie:
Code:

 rpm -q flash-plugin
flash-plugin-9.0.48.0-release

Heb je de repo van Adobe aan je yum-configuratie toegevoegd? Als dat het geval is, zou je met het commando:
Code:

yum -y update
de flash-plugin moeten updaten.
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Kluivertnr1



Geregistreerd op: 20 Jun 2007
Berichten: 36

BerichtGeplaatst: Ma Aug 13, 2007 11:30 am    Onderwerp: Reageren met citaat

Gul Dukat schreef:
Op zich niet erg vreemd, aangezien de laatst beschikbare versie:
Code:

 rpm -q flash-plugin
flash-plugin-9.0.48.0-release

Heb je de repo van Adobe aan je yum-configuratie toegevoegd? Als dat het geval is, zou je met het commando:
Code:

yum -y update
de flash-plugin moeten updaten.


Als ik het commando
Code:
yum -y update
intyp, komt er dit te staan

[root@localhost bertus]# yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
flash 100% |=========================| 1.9 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
jpackage-fedora 100% |=========================| 951 B 00:00
updates 100% |=========================| 1.2 kB 00:05
jpackage-generic 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package flash-plugin.i386 0:9.0.48.0-a set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
flash-plugin i386 9.0.48.0-a flash 2.5 M

Transaction Summary
=============================================================================
Install 0 Package(s)
Update 1 Package(s)
Remove 0 Package(s)

Total download size: 2.5 M
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
package flash-plugin-9.0.48.0-a is already installed

Error Summary
-------------

[root@localhost bertus]#

Wat betekent de a achter de laatste 0 eigenlijk?
Terug naar boven
Profiel bekijken Stuur privébericht
Gul Dukat



Geregistreerd op: 12 Okt 2005
Berichten: 1389
Woonplaats: Doetinchem

BerichtGeplaatst: Ma Aug 13, 2007 11:44 am    Onderwerp: Reageren met citaat

Ik vermoedt dat dat een versie is die voor de release versie is verschenen. Als je op de site van Adobe kijkt, de maker van de flash-plugin, zie je ook dat flash-plugin-9.0.48.0-release de laatste officiele versie is. En dus niet de a-versie die er bij jou opstaat. Wss geeft ie darom steeds aan dat er een update is. Overigens heb je hier een linkje naar de site van Adobe: http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&promoid=BIOW
Hier kun je ook lezen hoe je de repo aan je yum-configuratie kunt toevoegen en hoe je de flash-plugin kunt installeren.
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software Tijden zijn in GMT + 1 uur
Ga naar pagina 1, 2  Volgende
Pagina 1 van 2

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.