Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

HP Scanjet 3500C icm Sane

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Hardware
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Menno



Geregistreerd op: 29 Mei 2005
Berichten: 447

BerichtGeplaatst: Za Okt 21, 2006 11:26 am    Onderwerp: HP Scanjet 3500C icm Sane Reageren met citaat

Zojuist zag ik op de website van sane-project.org dat mijn HP 3500C scanner ondersteund wordt met backend 1.0.18.
Met yum update zag ik deze backend ook voorbij komen.

Alles mooi geinstalleerd en mijn scanner aangesloten, maar.. dan kan Sane hem niet vinden..

Ik heb het volgende geprobeerd:

cat /proc/bus/usb/devices
Code:
T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=03f0 ProdID=2205 Rev= 1.00
S:  Manufacturer=Hewlett-Packard
S:  Product=hp scanjet 3500c series
S:  SerialNumber=SCN295NB02M1P
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=   8 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   1 Ivl=250ms


sane-find-scanner -v -v
Code:
<Couldn't determine the type of the USB chip (result from sane-backends 1.0.18)>
found USB scanner (vendor=0x03f0, product=0x2205) at libusb:001:004


/usr/bin/scanimage -L
Code:
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


Linux ziet dus dat er een 3500C aanhangt, maar sane met de laatste backend kan er niks mee..wie weet er raad?
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Za Okt 21, 2006 3:58 pm    Onderwerp: Reageren met citaat

Probeer je als user of als root te scannen? Probeer eens als root; er zijn volgens mij wat problemen met libusb en normale users...
Terug naar boven
Profiel bekijken Stuur privébericht
Menno



Geregistreerd op: 29 Mei 2005
Berichten: 447

BerichtGeplaatst: Za Okt 21, 2006 6:36 pm    Onderwerp: Reageren met citaat

Heb het ook met root geprobeerd, maar dan werkt het ook niet.
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Zo Okt 22, 2006 11:01 am    Onderwerp: Reageren met citaat

Menno schreef:
Heb het ook met <a>root</a> geprobeerd, maar dan werkt het ook niet.


Gezien de kleine kans dat mensen hier toevallig ook een Scanjet 3500C hebben staan en op Fedora gebruiken denk ik dat je het best kan navragen op de Fedora-user en/of de Sane mailing lijsten...
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Okt 22, 2006 4:14 pm    Onderwerp: Reageren met citaat

Toevallig heb ik ook een 3500c (stond te stoffen omdat ik hem toch niet kon gebruiken). Ik gebruik nu mijn oude 6250 via een aparte SCSI kaart -- werkt uitstekend. En ik heb ook de backends 1.0.18.

Ik heb de 3500c aangesloten en sane-find-scanner vind hem:

Code:
found SCSI processor "HP C6270A 3824" at /dev/scanner
found SCSI processor "HP C6270A 3824" at /dev/sg3
  # Your SCSI scanner was detected. It may or may not be supported by SANE. Try
  # scanimage -L and read the backend's manpage.

found USB scanner (vendor=0x03f0, product=0x2205) at libusb:002:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

scanimage -L zegt echter:
Code:
device `hp:/dev/sg3' is a Hewlett-Packard C6270A flatbed scanner
device `hp:/dev/scanner' is a Hewlett-Packard C6270A flatbed scanner

Ik zie de 3500 ook niet in man sane-hp. Hoe kom je erbij dat deze nu zou worden gesupport?
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Menno



Geregistreerd op: 29 Mei 2005
Berichten: 447

BerichtGeplaatst: Zo Okt 22, 2006 4:16 pm    Onderwerp: Reageren met citaat

Citaat:
2006-07-03: SANE-Backends-1.0.18 has been released. Changes since 1.0.17:

New backends: dell1600n_net (Dell 1600n), hp3500 (HP ScanJet 3500 series), pixma (Canon Pixma series), stv680 (Aiptek Pencam and similar).
Updated backends: avision, canon, dll, epson, fujitsu, genesys, gt68xx, microtek2, mustek_pp, niash, plustek, snapscan, sp15c, test, u12, umax1220u.
Scanimage batch mode fixes.
Scanner lists contain USB vendor/product ids and some statistics now.
Udev/hotplug lists are generated autmatically from the .desc files now.
Portability fixes (especially for DragonFlyBSD and HP/UX).
Build system updates.
Updated translations.
Documentation updates.
Bugfixes.
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Zo Okt 22, 2006 6:42 pm    Onderwerp: Reageren met citaat

Menno schreef:
2006-07-03: SANE-Backends-1.0.18 has been released. Changes since 1.0.17:

New backends: dell1600n_net (Dell 1600n), hp3500 (HP ScanJet 3500 series),


Hij is dus later toegevoegd? Misschien helpt het als je even een regel met de tekst "hp3500" aan /etc/sane.d/dll.conf toevoegt. Dit is de cache met beschikbare scanner drivers en die wordt kennelijk niet automatisch bijgewerkt na een sane upgrade... bij mij is de file met hp3500 erin als .rpmnew neergezet omdat rpm default geen configuratie update.
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Zo Okt 22, 2006 8:19 pm    Onderwerp: Reageren met citaat

Klopt. Nu zegt scanimage -L
Code:
device `hp3500:libusb:002:003' is a Hewlett-Packard ScanJet 3500 scanner
device `hp:/dev/sg3' is a Hewlett-Packard C6270A flatbed scanner
device `hp:/dev/scanner' is a Hewlett-Packard C6270A flatbed scanner

Ik kan de scanner aanspreken, maar hij maakt vooralsnog alleen maar een hoop lawaai.t
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Menno



Geregistreerd op: 29 Mei 2005
Berichten: 447

BerichtGeplaatst: Zo Okt 22, 2006 8:52 pm    Onderwerp: Reageren met citaat

Hier doet ie het ook, alleen krijg ik wel horizontale strepen tijdens het scannen.
Iemand dit ook?
Het is al een hele stap dat er wat zichtbaars gescand kan worden!! Wink
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Ma Okt 23, 2006 7:53 am    Onderwerp: Reageren met citaat

Menno schreef:
Hier doet ie het ook, alleen krijg ik wel horizontale strepen tijdens het scannen.
Iemand dit ook?
Het is al een hele stap dat er wat zichtbaars gescand kan worden!! Wink


Zit het ding wel op een USB2 aansluiting? En doet die scanner het wel goed icm bijvoorbeeld de windows drivers?
Maar waarschijnlijk ben je nu toch echt beter af bij de Sane mailinglijst Wink
Terug naar boven
Profiel bekijken Stuur privébericht
Menno



Geregistreerd op: 29 Mei 2005
Berichten: 447

BerichtGeplaatst: Ma Okt 23, 2006 9:47 am    Onderwerp: Reageren met citaat

Nee zit op een USB 1.1 poort, maar dat maakt niet uit, gaat ie gewoon wat langzamer.
Ja deed het voorheen perfect Wink
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Ma Okt 23, 2006 10:15 am    Onderwerp: Reageren met citaat

Menno schreef:
Nee zit op een USB 1.1 poort, maar dat maakt niet uit, gaat ie gewoon wat langzamer.
Ja deed het voorheen perfect Wink


Sommige scanners doen het niet op USB1... maar als het op windows wel werkt denk ik toch echt aan een probleem met de driver (en daarvoor kan je het beste een bug aanmelden bij de Sane mensen).
Terug naar boven
Profiel bekijken Stuur privébericht
sciurius



Geregistreerd op: 28 Sep 2006
Berichten: 1473
Woonplaats: Exloo

BerichtGeplaatst: Ma Okt 23, 2006 8:55 pm    Onderwerp: Reageren met citaat

Ik heb mijn 3500 even aan het 'andere' systeem gehangen. Daar bleek dat hij tijdens het scannen steeds op een bepaalde plek bleef hangen. Scanner opengemaakt, even lief aangekeken, en toen scande hij weer.

Vervolgens xsane opgestart en hij doet het!

Weliswaar met wat aantekeningen. Zo lijkt het of een preview scan wordt gemaakt in start/stop mode. Dus een scanlijn, dan stop, dan space, dan weer een scanlijn. Maakt een herrie en is uiterst langzaam.
Gewoon scannen gaat ook erg traag, niet het glijdende zoals onder het 'andere' systeem. Maar in principe is er contact.

Nu de sane jongens raadplegen of dit de bedoeling is.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Hardware Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.