Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Apache Virtual Hosts
Ga naar pagina 1, 2  Volgende
 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Vr Mei 26, 2006 11:35 am    Onderwerp: Apache Virtual Hosts Reageren met citaat

Hallo, ben ik weer met me vragen:

Ik 2 domeins runnen www.perfect-hosted.be en tienernetwerk.be.. Alleen die tienernetwerk moet niet naar /var/www/html maar naar /home/Niels/public_html en ik heb dit en toch gaat hij naar /var/www/html:

Code:
<VirtualHost www.tienernetwerk.be:80>
    ServerAdmin webmaster@tienernetwerk.be
    DocumentRoot /home/Niels/public_html
    ServerName www.tienernetwerk.be
    CustomLog /home/Niels/tienernetwerk-access_log common
</VirtualHost>
Terug naar boven
Profiel bekijken Stuur privébericht
kanarip



Geregistreerd op: 17 Mrt 2006
Berichten: 286
Woonplaats: Utrecht

BerichtGeplaatst: Vr Mei 26, 2006 12:07 pm    Onderwerp: Reageren met citaat

Heb je een Directive

Code:
NameVirtualHost *:80


staan?

Heb je een

<VirtualHost _default_:80></VirtualHost> block?
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken Yahoo Messenger MSN Messenger
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Vr Mei 26, 2006 12:47 pm    Onderwerp: Reageren met citaat

Wat moet ik nou die NameVirtualHost *:80 ergens neerzetten en die virtual host van tienernetwerk erbij?
Terug naar boven
Profiel bekijken Stuur privébericht
kanarip



Geregistreerd op: 17 Mrt 2006
Berichten: 286
Woonplaats: Utrecht

BerichtGeplaatst: Vr Mei 26, 2006 6:02 pm    Onderwerp: Reageren met citaat

Ja?

Zo staat het in de handleiding, de default httpd.conf... Waar staat het eigenlijk niet?
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken Yahoo Messenger MSN Messenger
VaaG



Geregistreerd op: 20 Mei 2005
Berichten: 16
Woonplaats: Rotterdam

BerichtGeplaatst: Vr Mei 26, 2006 11:06 pm    Onderwerp: Reageren met citaat

Code:
<IfModule mod_userdir.c>
    #
    # UserDir is disabled by default since it can confirm the presence
    # of a username on the system (depending on home directory
    # permissions).
    #
    #UserDir disable

    #
    # To enable requests to /~user/ to serve the user's public_html
    # directory, remove the "UserDir disable" line above, and uncomment
    # the following line instead:
    #
    UserDir public_html

</IfModule>


Code:
#
# Use name-based virtual hosting.
#
NameVirtualHost 1.2.3.4


Code:
<VirtualHost www.perfect-hosted.be>
    DocumentRoot "/home/perfect/public_html"
    ServerName perfect-hosted
    <Directory "/home/perfect/public_html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>

<VirtualHost www.tienernetwerk.be>
    DocumentRoot "/home/tienernetwerk/public_html"
    ServerName tienernetwerk
    <Directory "/home/tienernetwerk/public_html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken MSN Messenger
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Za Mei 27, 2006 10:19 am    Onderwerp: Reageren met citaat

Code:
NameVirtualHost 192.168.1.103

<VirtualHost perfect-hosted.be>
    DocumentRoot "/var/www/html"
    ServerName perfect-hosted
    <Directory "/var/www/html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>

<VirtualHost tienernetwerk.be>
    DocumentRoot "/home/Niels/public_html"
    ServerName tienernetwerk
    <Directory "/home/Niels/public_html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>



Ik heb dit, ik start apache op en krijg dit:

Code:
[root@localhost ~]# service httpd restart
Stoppen van httpd:                                         [  OK  ]
Starten van httpd: [Sat May 27 10:21:17 2006] [warn] VirtualHost perfect-hosted.be:0 overlaps with VirtualHost tienernetwerk.be:0, the first has precedence, perhaps you need a NameVirtualHost directive
[Sat May 27 10:21:17 2006] [warn] NameVirtualHost 192.168.1.103:0 has no VirtualHosts
                                                           [  OK  ]


Maar hij werkt nog niet..
Terug naar boven
Profiel bekijken Stuur privébericht
david



Geregistreerd op: 16 Mei 2006
Berichten: 238
Woonplaats: amsterdam

BerichtGeplaatst: Za Mei 27, 2006 11:22 am    Onderwerp: Reageren met citaat

hoi,


[root@localhost ~]# service httpd restart
Stoppen van httpd: [ OK ]
Starten van httpd: [Sat May 27 10:21:17 2006] [warn] VirtualHost perfect-hosted.be:0 overlaps with VirtualHost tienernetwerk.be:0, the first has precedence, perhaps you need a NameVirtualHost directive
[Sat May 27 10:21:17 2006] [warn] NameVirtualHost 192.168.1.103:0 has no VirtualHosts
[ OK ]

de uitleg zegt het al volgens mij Smile

david
Terug naar boven
Profiel bekijken Stuur privébericht
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Za Mei 27, 2006 11:25 am    Onderwerp: Reageren met citaat

NameVirtualHost 192.168.1.103

Staat er toch?
Terug naar boven
Profiel bekijken Stuur privébericht
david



Geregistreerd op: 16 Mei 2006
Berichten: 238
Woonplaats: amsterdam

BerichtGeplaatst: Za Mei 27, 2006 11:41 am    Onderwerp: Reageren met citaat

hoi,

had ik even overheengekeken, ben ook geen apache expert Wink

probeer eens:

NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot "/var/www/html"
ServerName perfect-hosted
<Directory "/var/www/html">
allow from all
Options +Indexes +ExecCGI
</Directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "/home/Niels/public_html"
ServerName tienernetwerk
<Directory "/home/Niels/public_html">
allow from all
Options +Indexes +ExecCGI
</Directory>
</VirtualHost>


volgens mij moet wat er bij servername staat het adres zijn wat je in je browser invoert

david
Terug naar boven
Profiel bekijken Stuur privébericht
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Za Mei 27, 2006 11:54 am    Onderwerp: Reageren met citaat

Dat niet maar ik zal dit eens proberen; NameVirtualHost *:80


EDIT: Werkt ook niet
Terug naar boven
Profiel bekijken Stuur privébericht
david



Geregistreerd op: 16 Mei 2006
Berichten: 238
Woonplaats: amsterdam

BerichtGeplaatst: Za Mei 27, 2006 12:08 pm    Onderwerp: Reageren met citaat

heb je de 2 regels met:
VirtualHost *:80
ook aangepast?

david
Terug naar boven
Profiel bekijken Stuur privébericht
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Za Mei 27, 2006 12:13 pm    Onderwerp: Reageren met citaat

Code:
NameVirtualHost *:80

<NameVirtualHost perfect-hosted.be>
    DocumentRoot "/var/www/html"
    ServerName perfect-hosted
    <Directory "/var/www/html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</NameVirtualHost>

<NameVirtualHost tienernetwerk.be>
    DocumentRoot "/home/Niels/public_html"
    ServerName tienernetwerk
    <Directory "/home/Niels/public_html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</NameVirtualHost>




Als ik dat doe krijg ik dit:

Code:
[root@localhost]# service httpd restart
Stoppen van httpd:                                         [  OK  ]
Starten van httpd: Syntax error on line 992 of /etc/httpd/conf/httpd.conf:
Invalid command '<NameVirtualHost', perhaps misspelled or defined by a module not included in the server configuration
                                                           [MISLUKT]
[root@localhost]#
Terug naar boven
Profiel bekijken Stuur privébericht
david



Geregistreerd op: 16 Mei 2006
Berichten: 238
Woonplaats: amsterdam

BerichtGeplaatst: Za Mei 27, 2006 12:17 pm    Onderwerp: Reageren met citaat

hoi,

volgens mij moet je de regels:
<NameVirtualHost perfect-hosted.be>
en
<NameVirtualHost tienernetwerk.be>
beiden vervangen door:
<VirtualHost *:80>

de apache uitleg, met voorbeelden staat op :
http://httpd.apache.org/docs/2.2/vhosts/

david
Terug naar boven
Profiel bekijken Stuur privébericht
Nivko



Geregistreerd op: 14 Feb 2006
Berichten: 179

BerichtGeplaatst: Za Mei 27, 2006 12:23 pm    Onderwerp: Reageren met citaat

Dan heb ik het zo begrepen:

Code:
NameVirtualHost 192.168.1.103:80

<VirtualHost *:80>
    DocumentRoot "/var/www/html"
    ServerName perfect-hosted.be
    <Directory "/var/www/html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "/home/Niels/public_html"
    ServerName tienernetwerk.be
    <Directory "/home/Niels/public_html">
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
</VirtualHost>



Maar dan weer:

Code:
[root@localhost home]# service httpd restart
Stoppen van httpd:                                         [  OK  ]
Starten van httpd: [Sat May 27 12:26:34 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Sat May 27 12:26:34 2006] [warn] NameVirtualHost 192.168.1.103:80 has no VirtualHosts
                                                           [  OK  ]
[root@localhost home]#
Terug naar boven
Profiel bekijken Stuur privébericht
david



Geregistreerd op: 16 Mei 2006
Berichten: 238
Woonplaats: amsterdam

BerichtGeplaatst: Za Mei 27, 2006 12:25 pm    Onderwerp: Reageren met citaat

volegns mij is ie:



NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot "/var/www/html"
ServerName perfect-hosted.be
<Directory "/var/www/html">
allow from all
Options +Indexes +ExecCGI
</Directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "/home/Niels/public_html"
ServerName tienernetwerk.be
<Directory "/home/Niels/public_html">
allow from all
Options +Indexes +ExecCGI
</Directory>
</VirtualHost>



david
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Ga naar pagina 1, 2  Volgende
Pagina 1 van 2

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.