Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

gDesklets

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Ma Feb 06, 2006 12:56 pm    Onderwerp: gDesklets Reageren met citaat

Laatst kwam ik de site van gDesklet tegen en dat zag er wel leuk uit. Ik had, en heb nogsteeds, geen idee wat het inhoud maar wil het wel installeren. Ik heb hem dus gedownload en dan krijg je zo'n .tar.gz2 filetje wat allemaal nog goed gaat. Wanneer ik hem uitpak en open dan staat er ook een README, en daarin staat het volgende:

2. Requirements (the package names are the debian ones!)
---------------
* Python 2.3 or higher (some distributions ship broken Python 2.4 packages),
if you want to compile gdesklets you'll have to install the development
package, too!

* SuSE users will need the additional python-xml package, gDesklets won't
work without it!

* python-gtk2 2.4 or higher (*)

* python-gtk2-dev if you want to compile gDesklets

* python-pyorbit 2.0.1 (**)

* python-gnome2 2.6.x or higher (***)

* python-gnome2-dev if you want to compile gDesklets

* libexpat (try to avoid 1.95.7 since it seems to be buggy!)

* libgtop2 (2.8.0 or higher is recommended)

* libgtop2-dev if you want to compile gDesklets

* librsvg (2.8.0 or higher from http://librsvg.sf.net)

* librsvg-dev if you want to compile gDesklets

* some sensors or controls may have extra requirements

The following remarks apply to Mandrake 10.1, SuSE 9.2 and Fedora Core 3. Of
course, they apply to older versions as well:

(*) SuSE, Mandrake and Fedora 2 & 1 are shipping versions which are too old,
so you will have to find newer versions, the ones currently shipped will not
work! You can try to find them at rpmseek.com or rpmfind.net.

(**) Recent Mandrake and older SuSE or Fedora versions ship 2.0.0 which won't
work; you have to upgrade to 2.0.1.

(***) SuSE, Mandrake and Fedora 2 & 1 are shipping old versions; please find
newer versions for your distribution. These distributions split up
gnome-python2 in small packages. To avoid problems install every gnome-python2
package.

Debian Sarge has all the necessary packages and should work out of the box.
gDesklets won't work on older versions of Debian.

Pascal Bleser created some packages for SuSE 9.2. They are available at
http://linux01.gwdg.de/~pbleser/


Ik heb dus de meeste packeges wel geinstalleerd en de helft was al geinstalleerd maar bij verschillende pakketen blijf ik haken. Op een een of andere manier moest ik weer via via GTK+2 installeren en daar ben ik nu dan ook mee bezig.
GTK+ is natuurlijk ook weer afhankelijk van verschillende dingen waarvan ik de helft al geinstalleerd heb maar blijf weer bij een paar haken. Zo ook bij Glib. Er staat al een rpm geinstalleerd op mijn pc alleen dat is een verouderde versie. Nu probeer ik hem dus te installeren met een uitgepakt tar.gzip filetje en dan zeggen ze dat je het volgende moet doen:

$ ./configure
$ make
$ make install


Standaard procedure. Alleen nu ga ik weer kijken d.m.v:

$ rpm -q glib

en daar staat nog de oude versie. Hoe moet ik dit oplossen want dit heb ik bij de meeste packeges die ik wil installeren. Ik weet niet of ik dan de rpm dingen eerst moet weghalen voordat ik het ga installeren. Heb ik nog niet gedaan want ik ben als de doods dat ik iets verkeerds weghaal en dat dan heel mijn systeem crachsed wanneer ik hem weer wil opstarten.

Alvast bedankt.


Laatst aangepast door Th3No0b op Ma Feb 06, 2006 7:47 pm; in totaal 2 keer bewerkt
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Ma Feb 06, 2006 4:02 pm    Onderwerp: Reageren met citaat

En daar komt nog eens bij dat ik ook nog atk moet updaten want die is ook niet nieuw genoeg. Ik kan van alles wel van die .tar.gz bestanden vinden enzo alleen dat installeren werkt bij mij nooit. Daar zit ik echt mee. Ik weet wel hoe ik het moet installeren allen het werkt gewoon niet. Ik zoek me al de hele tijd suf naar rpm packeges alleen die kan ik ook niet vinden.

Iemand die hier iets op weet heel graag.

Alvast bedankt.
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Ma Feb 06, 2006 4:29 pm    Onderwerp: Reageren met citaat

Hoe kom ik erachter of er iets geinstalleerd is wanneer ik het zonder rpm doe en gewoon via command line. Ik heb al verschillende dingen geprobeerd maar het ene doet het wel en het andere weer niet.

Ik ben momenteel bezig met GTK+2 alleen daar blijf ik haken bij:

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.8.5 atk >= 1.0.1 pango >= 1.9.0 cairo >= 0.9.2) were not met.

Ik heb glib al honderden keren geprobeerd om te installeren alleen hij blijf bij de oude versie en atk hetzelfde liedje en pango heb ik ook al verscheidene keren geprobeerd alleen dan installeer ik hem volgens mij wel maar ik kan nergens terug vinden dat ik het geinstalleerd heb. Met cairo is dat ook. Heb ik ook al verschillende keren geprobeerd.

Kan niet iemand even snel komen met een oplossing omdat ik het niet leuk vind om met onopgeloste zaken te blijven zitten Razz Dat vind ik niet leuk.

Alvast bedankt.

Edit \

Ik kom er net achter dat Pango ook gebruik maakt van GLib:

Dependencies
============

Pango depends on version 2.6.0 or newer of the GLib library; more
information about GLib can be found at http://www.gtk.org/.


Dus zo'n beetje alles hangt af van GLib, wat ik niet geinstalleerd krijg.
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Ma Feb 06, 2006 7:21 pm    Onderwerp: Reageren met citaat

Kun je met Yum ook gDesklet installeren? Als je het zelf hebt geinstalleerd, hoe heb jij dat dan gedaan?
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Ma Feb 06, 2006 8:31 pm    Onderwerp: Reageren met citaat

Okej,

Ik heb mijn pc vernaggeld Razz Is het nog mogenlijk om zoveel mogenlijk te laten staan en dan gewoon opnieuw te installeren? Pango ofzo doet het niet meer Razz

Edit \

Ik ben er nu wel achter hoe je gDesklets geinstalleerd krijgt. Gewoom met een rpm maar daar is het nu te laat voor. Dat wordt even her installeren denk ik maar.
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Ma Feb 06, 2006 10:20 pm    Onderwerp: Reageren met citaat

Th3No0b,

was eventjes bezig met iets anders, ik had deze middag je message al gezien. Had beter toen gereageerd. gdesklets kan je installeren via rpm/yum.
maar, ik had teveel *werk* hé. ik haat het wanneer ik geen tijd hebt.

waarom herinstalleren. je systeem werkt toch nog, of niet ?
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Wo Feb 08, 2006 9:13 am    Onderwerp: Reageren met citaat

Ik heb hem nu al opnieuw geinstalleerd want ik had Pango verprutst ofzo. Daardoor kon ik Yumex en Yum niet gebruiken? Ik heb niet geprobeerd om andere dingen te proberen.

Heb het nu dus opnieuw geinstalleerd en alles werkt nu ook gewoon. Had een lijstje gemaakt met wat allemaal op mijn pc stond. Heb daar alles al weer van geinstalleerd op mijn pc. Allemaal via Yum en wat Repositities.
Dat gaat veel beter en werkt perfect. Ik heb nog geen spijt van dat ik het opnieuw heb geinstalleerd.
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.