Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

vsftpd upload?

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
K3s99



Geregistreerd op: 02 Nov 2005
Berichten: 42
Woonplaats: Dordrecht

BerichtGeplaatst: Wo Feb 01, 2006 8:44 am    Onderwerp: vsftpd upload? Reageren met citaat

ftp server opgezet en werkt, maar het volgende probleem doet zich voor.
Als ik inlog als gebruiker waar mijn systeem onder draait, kan ik up en downloaden. Waneer ik nu inlog als gebruiker welke ik speciaal heb aangemaakt voor ftp gebruik, kan ik alleen maar downloaden. Ik ben hier al een paar dagen mee aan het stoeien, en heb voor zover ik weet alles geprobeerd. Waarschijnlijk vergeet ik ergens iets simpels maar wat?
Is er iemand die mij nog een hint kan geven??
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Wo Feb 01, 2006 9:13 am    Onderwerp: Reageren met citaat

Probeer die gebruiker eens de autoritieten om te uploaden te geven, dus dat hij gegevens kan veranderen op de pc. Volgens mij moet het dan wel werken.
Terug naar boven
Profiel bekijken Stuur privébericht
K3s99



Geregistreerd op: 02 Nov 2005
Berichten: 42
Woonplaats: Dordrecht

BerichtGeplaatst: Wo Feb 01, 2006 4:42 pm    Onderwerp: Reageren met citaat

de gebruiker waarmee ik inlog is eigenaar van de map en lid van de groep die eigenaar is van de map waar in geschreven moet worden, de rechten op de map staan op 777.
Helaas kom ik niet verder dan down loaden van bestanden, en krijg keer op keer de melding - 553 Could not create file - als ik probeer iets te uploaden.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
samav



Geregistreerd op: 31 Jan 2006
Berichten: 9

BerichtGeplaatst: Wo Feb 01, 2006 5:46 pm    Onderwerp: Reageren met citaat

Tis mss simpel maar start je vsftpd elke keer opnieuw op als je veranderingen doorvoert?
Terug naar boven
Profiel bekijken Stuur privébericht
K3s99



Geregistreerd op: 02 Nov 2005
Berichten: 42
Woonplaats: Dordrecht

BerichtGeplaatst: Wo Feb 01, 2006 6:12 pm    Onderwerp: Reageren met citaat

Jazeker, dat lijkt me nogal voor de hand liggen.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
samav



Geregistreerd op: 31 Jan 2006
Berichten: 9

BerichtGeplaatst: Wo Feb 01, 2006 6:23 pm    Onderwerp: Reageren met citaat

K3s99 schreef:
Jazeker, dat lijkt me nogal voor de hand liggen.

Natuurlijk.Kan het niet aan je firewall liggen?Selinux?
Terug naar boven
Profiel bekijken Stuur privébericht
K3s99



Geregistreerd op: 02 Nov 2005
Berichten: 42
Woonplaats: Dordrecht

BerichtGeplaatst: Wo Feb 01, 2006 6:31 pm    Onderwerp: Reageren met citaat

Sellinux en firewal zodanig ingesteld dat dit ook niet het probleen kan zijn.
Als ik namelijk via ftp al normale gebruiker inlog, niet als gebruiker die ik speciaal voor ftp heb gemaakt, dan kan ik namelijk wel in mijn home dir uploaden. Ik heb dus alle settings voor de ftp user gelijk gezet aan die waar ik normaal mee inlog op het systeem.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
samav



Geregistreerd op: 31 Jan 2006
Berichten: 9

BerichtGeplaatst: Wo Feb 01, 2006 6:58 pm    Onderwerp: Reageren met citaat

Post je vsftpd.conf eens?
Terug naar boven
Profiel bekijken Stuur privébericht
K3s99



Geregistreerd op: 02 Nov 2005
Berichten: 42
Woonplaats: Dordrecht

BerichtGeplaatst: Wo Feb 01, 2006 7:08 pm    Onderwerp: Reageren met citaat

Dit is mijn vsftpd.config file


ftp_username=ftp-user
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
anon_upload_enable=NO
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
anon_mkdir_write_enable=NO
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
chroot_local_user=NO
# users to NOT chroot().
chroot_list_enable=YES
# (default follows)
chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES

pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES
force_dot_files=NO
#listen_address=
#hide_file=
#anon_max_rate=
#local_max_rate=
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Wo Feb 01, 2006 11:32 pm    Onderwerp: Reageren met citaat

K3s99,

hm, rare history. heb eens dezelfde config hier opgezet en kan alles perfect up en downloaden. Wel alles lokaal uitgetest met ftp localhost.

de user voor ftp heb ik gewoon als volgt aangemaakt :
useradd william4
passwd william4

een directory testftp aangemaakt in /home/william4 en die als rechten
chown -R william4 testftp
chmod 777 testftp
en dan kan ik mbv ftp up en downloaden naar die directory.
ls -Z /home/william4
drwxrwxrwx 502 502 root:object_r:user_home_t testftp

juist dezelfde vsftpd.conf als jij.
een chroot_list file aangemaakt
een user_list
alsook ftpusers en /etc/pam.d/vsftpd gecheckt.
Dit alles volgens de wiki.

werkt perfect
Terug naar boven
Profiel bekijken Stuur privébericht
wge



Geregistreerd op: 17 Nov 2005
Berichten: 320
Woonplaats: Roeselare

BerichtGeplaatst: Vr Feb 03, 2006 11:31 am    Onderwerp: Reageren met citaat

K3s99,

gerelateerd topic : http://fedora-linux.nl/forum/viewtopic.php?t=441

dan lijkt het mij normaal dat mijn testen allemaal lokaal lukken.
Terug naar boven
Profiel bekijken Stuur privébericht
K3s99



Geregistreerd op: 02 Nov 2005
Berichten: 42
Woonplaats: Dordrecht

BerichtGeplaatst: Za Feb 04, 2006 7:46 am    Onderwerp: Reageren met citaat

Forum leden,
bedankt voor de input, ben nog een keer kompleet overnieuw begonnen. Ook vsftpd opnieuw geinstaleerd. Alles gedaan zoals de eerste keer (gebruikers aangemaakt,rechten toegewezen enz.) Lijkt verdacht veel op post van william, nu werkt ftp gedeelte zoals verwacht.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.