Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Citrix Client installatie in FC5

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Ma Mrt 27, 2006 3:31 pm    Onderwerp: Citrix Client installatie in FC5 Reageren met citaat

Probeer de laatste citrix client 9.0 in FC5 te installeren, maar dat wil dusniet lukken.
Hij blijft maar zeuren om de volgende file libXm.so.3. Voor zover ik kan nagaan is die file van Openmotif 2.2.x. In FC5 draait versie 2.3.0 van openmotif..

Is er iemand die het voor elkaar heeft gekregen om de Citrix ICA client te installeren...
Voor mijn werk heb ik die soms nodig en kan ik niet volstaan met een RDP verbinding...
Terug naar boven
Profiel bekijken Stuur privébericht
kanarip



Geregistreerd op: 17 Mrt 2006
Berichten: 286
Woonplaats: Utrecht

BerichtGeplaatst: Di Mrt 28, 2006 4:25 pm    Onderwerp: Reageren met citaat

Wat is het resultaat wanneer je:

ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3

daarna Citrix probeert te installeren / starten?
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken Yahoo Messenger MSN Messenger
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Di Mrt 28, 2006 6:20 pm    Onderwerp: Reageren met citaat

kanarip schreef:
Wat is het resultaat wanneer je:

ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3

daarna Citrix probeert te installeren / starten?


Dat werk dus niet heb het geprobeerd, maar hij blijft roepen dat hij die niet geinstalleerd is.
Terug naar boven
Profiel bekijken Stuur privébericht
kanarip



Geregistreerd op: 17 Mrt 2006
Berichten: 286
Woonplaats: Utrecht

BerichtGeplaatst: Za Apr 01, 2006 5:12 pm    Onderwerp: Reageren met citaat

Ik heb hier hetzelfde probleem.
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken Yahoo Messenger MSN Messenger
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Zo Apr 02, 2006 1:17 pm    Onderwerp: Reageren met citaat

kanarip schreef:
Ik heb hier hetzelfde probleem.


Dat wordt dus verder zoeken... Jammer.. Kan de citrix client goed gebruiken voor mijn werk....

/Edit1
Ben aan het zoeken geslagen en er achter gekomen dat de 8.0 versie wel te installeren is.. Alleen kan je geen update doen naar 9.0... Dan klaagt hij nog steeds...

Maar beter iets dan niets..
Even zoeken bij http://rpm.pbone.net op icaclient en je kan die oudere versie installeren..

/Edit2

De V8.0 wil wel installeren, maar niet werken.. Hij klaagt dat Wfica niet draait of zo iets.. Verder doet hij niets.... Dus weer verder zoeken..
Terug naar boven
Profiel bekijken Stuur privébericht
kanarip



Geregistreerd op: 17 Mrt 2006
Berichten: 286
Woonplaats: Utrecht

BerichtGeplaatst: Ma Apr 03, 2006 1:02 pm    Onderwerp: Reageren met citaat

Op het forum van Citrix beoogt men als oplossing openmotif-2.2.3 te installeren, --force en --nodeps, om vervolgens de /usr/lib/X11R6/libXm.so.3 te symlinken naar de geinstalleerde /usr/lib/X11R6/libXm.so.3.0.2

Echter, dan blijft bij applicaties die seamless draaien het probleem dat deze niet te minimaliseren zijn.
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken Yahoo Messenger MSN Messenger
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Ma Apr 03, 2006 1:34 pm    Onderwerp: Reageren met citaat

kanarip schreef:
Op het forum van Citrix beoogt men als oplossing openmotif-2.2.3 te installeren, --force en --nodeps, om vervolgens de /usr/lib/X11R6/libXm.so.3 te symlinken naar de geinstalleerde /usr/lib/X11R6/libXm.so.3.0.2

Echter, dan blijft bij applicaties die seamless draaien het probleem dat deze niet te minimaliseren zijn.


Na mijn weekje niets doen zal ik eens kijken... Very Happy
Terug naar boven
Profiel bekijken Stuur privébericht
boukej



Geregistreerd op: 09 Apr 2006
Berichten: 19

BerichtGeplaatst: Zo Apr 09, 2006 3:15 pm    Onderwerp: Reageren met citaat

Ik heb het als volgt opgelost:

- linuxx86.tar.gz gedownload
- linuxx86.tar.gz uitgepakt
- setupwfc uitgevoerd
- -- target is /opt/ICAClient
- ln libXm.so libXm.so.3 uitgevoerd in /usr/lib/

Voor Firefox 1.5.0.1

Code:
ln -s /opt/ICAClient/npica.so /usr/lib/firefox-1.5.0.1/plugins/npica.so
ln -s /opt/ICAClient/libctxssl.so /usr/lib/firefox-1.5.0.1/plugins/libctxssl.so


[edit]De plugins lijken niet te werken. Ik moet eerst n's uitzoeken hoe dit nou weer bedoeld is. Is hier iets mee verandert in deze versie?[/edit]


Laatst aangepast door boukej op Ma Apr 10, 2006 10:44 am; in totaal 1 keer bewerkt
Terug naar boven
Profiel bekijken Stuur privébericht
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Zo Apr 09, 2006 8:23 pm    Onderwerp: Reageren met citaat

boukej schreef:
Ik heb het als volgt opgelost:

- linuxx86.tar.gz gedownload
- linuxx86.tar.gz uitgepakt
- setupwfc uitgevoerd
- -- target is /opt/ICAClient
- ln libXm.so libXm.so.3 uitgevoerd in /usr/lib/

Voor Firefox 1.5.0.1

Code:
ln -s /opt/ICAClient/npica.so /usr/lib/firefox-1.5.0.1/plugins/npica.so
ln -s /opt/ICAClient/libctxssl.so /usr/lib/firefox-1.5.0.1/plugins/libctxssl.so


Werkt prima.


Hoe maak jij nu verbinding met een citrix server... Als ik de terminal client gebruikt dan krijg ik een error..

FAILED TO EXECUTE CHILD PROCESS "WFICA" (NO SUCH FILE OR DIRECTORY)

en

FAILED TO SPAWN..
Terug naar boven
Profiel bekijken Stuur privébericht
kanarip



Geregistreerd op: 17 Mrt 2006
Berichten: 286
Woonplaats: Utrecht

BerichtGeplaatst: Ma Apr 10, 2006 8:24 am    Onderwerp: Reageren met citaat

Zet /opt/ICAClient oid eens in je PATH environment variabele?
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken Yahoo Messenger MSN Messenger
boukej



Geregistreerd op: 09 Apr 2006
Berichten: 19

BerichtGeplaatst: Ma Apr 10, 2006 10:41 am    Onderwerp: Reageren met citaat

kanarip schreef:
Zet /opt/ICAClient oid eens in je PATH environment variabele?


Dat is een prima oplossing. Wordt ook aangedragen door de installer zelf.

Het kan ook als volgt: wanneer ik via de webbrowser een applicatie aanklik, dan open ik deze met wfica.sh. Hierin wordt ICAROOT netjes meegenomen.

Code:
#!/bin/sh
ICAROOT=/opt/ICAClient
export ICAROOT
$ICAROOT/wfica -file $1


Ik hoef maar een keer naar /opt/ICAClient/wfica.sh te browsen. Dat is alles.
Terug naar boven
Profiel bekijken Stuur privébericht
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Di Apr 11, 2006 10:15 am    Onderwerp: Reageren met citaat

Bedankt boy's het werkt... Tenminste, kan de ica client nu opstarten...

Alleen loopt ik nu tegen het probleem aan dat ik geen tekst kan intypen als ik een connectie heb met een server.. Daar ben ik nog niet achter..

Maar heb tenminste al iets.. Surprised

/Edit: Foutje van mij.... Laughing
Heb het nu aan de gang.. alles werkt perfect...
Terug naar boven
Profiel bekijken Stuur privébericht
vince



Geregistreerd op: 11 Apr 2006
Berichten: 1

BerichtGeplaatst: Di Apr 11, 2006 4:55 pm    Onderwerp: /etc/ld.so.conf Reageren met citaat

Hi,
the lib seems to be installed with me as well, but i found out that (in debian) the location is not standard; it ends up in
/usr/X11R6/lib/libXm.so.3
this is a symlink to the 'real' lib in this directory.
You can
1. cd /usr/lib
ln -s /usr/X11R6/lib/libXm.so.3

to make a symlink

2. add /usr/X11R6/lib to /etc/ld.so.conf (this file does not exsist always, you can create it) and run ldconfig

The second method is better.

O, ja dat was ff engels. Nouja. Succes,

--edit--
if you install libmotif3 (from non-free in debian) you don't have to change anything, it will work out of the box)
--/edit--

vince


Laatst aangepast door vince op Do Apr 20, 2006 12:38 pm; in totaal 1 keer bewerkt
Terug naar boven
Profiel bekijken Stuur privébericht
supernova



Geregistreerd op: 23 Mrt 2006
Berichten: 24

BerichtGeplaatst: Di Apr 11, 2006 7:39 pm    Onderwerp: Re: /etc/ld.so.conf Reageren met citaat

vince schreef:
Hi,
the lib seems to be installed with me as well, but i found out that (in debian) the location is not standard; it ends up in
/usr/X11R6/lib/libXm.so.3
this is a symlink to the 'real' lib in this directory.
You can
1. cd /usr/lib
ln -s /usr/X11R6/lib/libXm.so.3

to make a symlink

2. add /usr/X11R6/lib to /etc/ld.so.conf (this file does not exsist always, you can create it) and run ldconfig

The second method is better.

O, ja dat was ff engels. Nouja. Succes,


vince


In FC5 staat daar dus niets... Ja een diretory met uiteindelijk daar onder een config bestand voor X11.. Dus helaas gaat dit blijkbaar voor FC5 niet op..

Maar met de beschreven methode hierboven werkt alles perfect...
Terug naar boven
Profiel bekijken Stuur privébericht
boukej



Geregistreerd op: 09 Apr 2006
Berichten: 19

BerichtGeplaatst: Wo Mei 17, 2006 7:37 am    Onderwerp: Reageren met citaat

ICAClient werkt niet meer na kernel-upgrade.

Na het aanpassen van de security context, lijkt 't weer te werken. Ik krijg alleen nog geen verbinding (kan aan de term server liggen).

Code:
su
chcon -t texrel_shlib_t /opt/ICAClient/CHARICONV.DLL
chcon -t texrel_shlib_t /opt/ICAClient/libctxssl.so
chcon -t texrel_shlib_t /opt/ICAClient/PDCRYPT1.DLL


-- Edit --

Via: "System / Administration / Security Level & Firewall / SELinux / Modify SELinux Policy / Compatibility / Allow the use of shared libraries with Text Relocation" heb ik het beleid van SELinux aangepast.

Daarna heb ik ICA Client verwijderd (via setupwfc) en vervolgens opnieuw geinstalleert in de default directory (/usr/lib/ICAClient).

Uiteraard heb ik npica.so toegevoegd (link) aan de plugin-map van Firefox: ln -s /usr/lib/ICAClient/npica.so /usr/lib/firefox-1.5.0.3/plugins/npica.so

Werkt nu weer prima.
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Software Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.