Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

Terug naar PHP 4

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Daniel Bwa



Geregistreerd op: 13 Jan 2006
Berichten: 9
Woonplaats: Amsterdam

BerichtGeplaatst: Do Mrt 02, 2006 4:18 pm    Onderwerp: Terug naar PHP 4 Reageren met citaat

Had tijdens de install gekozen voor de meegeleverde php 5....

Alles draait top, alleen heb ik nu een script waar ik toch echt php 4 voor moet hebben draaien. Iemand een tip hoe ik dit het beste kan doen?

ik heb al gekeken naar Xampp alleen twijvel ik nu over het uninstallen van de apache,mysql,php wat nu draait (of hoeft dit niet om xampp te draaien?) kan ik de webserver met yum unistallen?


Alvast bedankt!

Mvg
Daniel
Terug naar boven
Profiel bekijken Stuur privébericht
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Vr Mrt 03, 2006 10:03 am    Onderwerp: Re: Terug naar PHP 4 Reageren met citaat

Daniel Bwa schreef:
Had tijdens de install gekozen voor de meegeleverde php 5....
Alles draait top, alleen heb ik nu een script waar ik toch echt php 4 voor moet hebben draaien. Iemand een tip hoe ik dit het beste kan doen?

Je kan een complete Apache+PHP+MySQL installatie naast de Fedora packages installeren, maar ook zelf RPM packages bouwen voor alleen PHP. Het probleem waar je dan misschien tegenaan loopt is of het mogelijk is een oudere PHP tegen een andere Apache/MySQL versie te bouwen. Vaak moet je de RPM "spec" file iets aanpassen..

Fedora kenmerkt zich door het snel upgraden naar nieuwe package versies. Het idee is natuurlijk niet dat jouw scripts in PHP4 blijven hangen maar dat ze worden ge-update zodat ze met nieuwere versies werken.

Wil je oudere versies kan je misschien ook een meer stabiele distributie zoals bv. Centos gebruiken. Dat is een Red Hat enterprise Linux kloon, dus werkt nagenoeg hetzelfde qua inrichting als Fedora. Alleen worden packages minder snel aangepast. De huidige versie wordt ook nog steeds met PHP4 geleverd.
Terug naar boven
Profiel bekijken Stuur privébericht
Daniel Bwa



Geregistreerd op: 13 Jan 2006
Berichten: 9
Woonplaats: Amsterdam

BerichtGeplaatst: Vr Mrt 03, 2006 11:59 am    Onderwerp: Reageren met citaat

Natuurlijk zal het php script aangepast moeten worden naar versie 5, alleen om het nu weer snel te laten draaien zal ik toch terug moeten naar 4.

Ik heb apache,php,mysql geuninstald met yum en daarna Xampp geinstald, best een leuk pakketje maar ik heb de service's toch liever "normaal" geinstald maar goed.....

Leuk detail van Xampp is dat je met een commando kan switchen tussen php 4 of 5. Dus voor nu heb ik een oplossing te pakken Wink
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.