Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

nVidia drivers onder Fedora Core 4

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Hardware
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Do Dec 15, 2005 5:31 pm    Onderwerp: nVidia drivers onder Fedora Core 4 Reageren met citaat

Ik heb zojuist geupgrade naar Fedora Core 4 (vanaf Fedora Core 2). Bij de installatie ging iets mis, waardoor ik mijn vorige linux installatie niet kon upgraden. Jammer, maar helaas, volledige herinstallatie dus. Maar nu wil ik de nVidia drivers voor mijn videokaart installeren. Normaalgesproken ga je hiervoor naar runtime level 3. Maar als ik dat op mijn nieuwe installatie probeer, gaat er iets fout. X wordt er uit gegooid, en dan kijk ik voor de rest tegen een zwart scherm aan. De computer reageert dan nergens meer op, en de enige optie is reset.

Weet iemand wat hier aan te doen is?
Terug naar boven
Profiel bekijken Stuur privébericht
Worado



Geregistreerd op: 13 Feb 2005
Berichten: 501
Woonplaats: Goes

BerichtGeplaatst: Do Dec 15, 2005 5:36 pm    Onderwerp: Reageren met citaat

Ik weet niet hoe je hebt geprobeert te installeren, maar de makkelijkste en snelste manier lijkt mij toch echt yum: http://www.fedora-linux.nl/fedorafaq/index.php?layout=fedorastyle#nvidia
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Do Dec 15, 2005 6:06 pm    Onderwerp: Reageren met citaat

Ok dan! Ik wist niet dat er nog een makkelijkere manier was! Bedankt Smile

Maar toch blijft het vreemd dat hij blijft hangen als je naar runtime level 3 gaat...
Terug naar boven
Profiel bekijken Stuur privébericht
jouke



Geregistreerd op: 20 Mrt 2005
Berichten: 29

BerichtGeplaatst: Vr Dec 16, 2005 6:52 pm    Onderwerp: Reageren met citaat

Heb ik bij de hand gehad. Bij mij werkte als oplossing Ctrl-Alt-F6, maar de F6 kan net zo goed F1 t/m F5 zijn.
Terug naar boven
Profiel bekijken Stuur privébericht
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Za Dec 17, 2005 10:48 am    Onderwerp: Reageren met citaat

Dan kom je idd bij het command prompt, maar sluit hij dan ook echt X af?
Terug naar boven
Profiel bekijken Stuur privébericht
Anoniem3



Geregistreerd op: 21 Okt 2005
Berichten: 51

BerichtGeplaatst: Za Dec 17, 2005 6:32 pm    Onderwerp: Reageren met citaat

waarvoor ga je naar runlevel 3??

voer uit wat in de link staat die Worado gaf.

Daarna evetueel re-booten en......klaar
Terug naar boven
Profiel bekijken Stuur privébericht
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Za Dec 17, 2005 9:57 pm    Onderwerp: Reageren met citaat

Omdat ik eerst op Fedora Core 2 werkte, en ik het toen op deze manier heb gedaan Razz
Terug naar boven
Profiel bekijken Stuur privébericht
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Zo Dec 18, 2005 11:04 am    Onderwerp: Reageren met citaat

Ik heb nog een heleboel lopen proberen, maar ik kom er niet uit...

Als ik de instructies van Worado volg, gebeurt er dit:

Citaat:
[root@Vigor10 KillerSponge]# yum install nvidia-glx kernel-module-nvidia-`(uname -r)`
Setting up Install Process
Setting up repositories
livna 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nvidia-glx.i386 0:1.0.8174-0.lvn.1.4 set to be updated
---> Package kernel-module-nvidia-2.6.11-1.1369_FC4.i686 0:1.0.7174-0.lvn.4.4 set to be updated
--> Running transaction check
--> Processing Dependency: nvidia-glx = 0:1.0.7174 for package: kernel-module-nvidia-2.6.11-1.1369_FC4
--> Processing Dependency: kernel-module-nvidia = 0:1.0.8174 for package: nvidia-glx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-module-nvidia-2.6.14-1.1644_FC4.i686 0:1.0.8174-0.lvn.1.4 set to be updated
--> Running transaction check
--> Processing Dependency: /boot/vmlinuz-2.6.14-1.1644_FC4 for package: kernel-module-nvidia-2.6.14-1.1644_FC4
Importing Additional filelist information for dependency resolution
--> Processing Dependency: nvidia-glx = 0:1.0.7174 for package: kernel-module-nvidia-2.6.11-1.1369_FC4
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.14-1.1644_FC4 set to be installed
--> Running transaction check
--> Processing Dependency: nvidia-glx = 0:1.0.7174 for package: kernel-module-nvidia-2.6.11-1.1369_FC4
--> Finished Dependency Resolution
Error: Missing Dependency: nvidia-glx = 0:1.0.7174 is needed by package kernel-module-nvidia-2.6.11-1.1369_FC4


En vervolgens is er geen driver ge´nstalleerd... Weet iemand wat hier mis is? Sad
Terug naar boven
Profiel bekijken Stuur privébericht
kiemo



Geregistreerd op: 22 Aug 2005
Berichten: 203
Woonplaats: Amersfoort

BerichtGeplaatst: Zo Dec 18, 2005 6:59 pm    Onderwerp: Reageren met citaat

KillerSponge schreef:
En vervolgens is er geen driver ge´nstalleerd... Weet iemand wat hier mis is? Sad


Hey,

Gebruik je wel een goeie yum.conf
die voor FC4 dus.
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Za Dec 24, 2005 11:39 pm    Onderwerp: Reageren met citaat

Ja, ik heb de goede ge´nstaleerd... Tenminste, ik heb de instructies op de site opgevolgd Smile

Iemand een ander idee? :S
Terug naar boven
Profiel bekijken Stuur privébericht
kiemo



Geregistreerd op: 22 Aug 2005
Berichten: 203
Woonplaats: Amersfoort

BerichtGeplaatst: Zo Dec 25, 2005 10:38 am    Onderwerp: Reageren met citaat

Hey,

Heb je de Development tools geinstalleerd?
Open een terminal en word root. type:
# yum groupinstall "Development Tools" <enter>

Dat kan het probleem van
Citaat:
Error: Missing Dependency: nvidia-glx = 0:1.0.7174 is needed by package kernel-module-nvidia-2.6.11-1.1369_FC4
oplossen.
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
Beer



Geregistreerd op: 17 Feb 2005
Berichten: 473

BerichtGeplaatst: Zo Dec 25, 2005 6:20 pm    Onderwerp: Reageren met citaat

Je probeert alles in een keer te doen. Er wordt namelijk gemeld dat er een nieuwe kernel wordt geinstalleerd.
    vmlinuz-2.6.14-1.1644
Waarna er direct een kernelmodule in wordt geladen
    nvidia-glx = 0:1.0.7174 for package: kernel-module-nvidia-2.6.11
En dit gaat niet lukken met je huidige kernel. Tevens is de module ongelijk aan de kernel release. Nu hoeft dat geen probleem te zijn maar slimmer is het om eerst de kernel te installeren en daarna de modulen, welke geladen moeten worden in de kernel. Dus iets in de trant van
    yum -y install nvidia-glx
en daarna
    yum -y install kernel-module-nvidia-`(uname -r)`
Terug naar boven
Profiel bekijken Stuur privébericht
KillerSponge



Geregistreerd op: 12 Dec 2005
Berichten: 15

BerichtGeplaatst: Do Jan 05, 2006 12:46 pm    Onderwerp: Reageren met citaat

Hallo, daar ben ik weer,

Ik heb beide tips opgevolgd, maar geen van beiden lijkt te werken...

Citaat:
[root@Vigor10 ~]# yum -y install kernel-module-nvidia-`(uname -r)`
Setting up Install Process
Setting up repositories
livna 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-module-nvidia-2.6.11-1.1369_FC4.i686 0:1.0.7174-0.lvn.4.4 set to be updated
--> Running transaction check
--> Processing Dependency: nvidia-glx = 0:1.0.7174 for package: kernel-module-nvidia-2.6.11-1.1369_FC4
--> Finished Dependency Resolution
Error: Missing Dependency: nvidia-glx = 0:1.0.7174 is needed by package kernel-module-nvidia-2.6.11-1.1369_FC4


Dit krijg ik als foutmelding...
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Hardware Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.