Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

update openoffice

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Installatie
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
jan



Geregistreerd op: 28 Sep 2005
Berichten: 8

BerichtGeplaatst: Wo Sep 28, 2005 1:03 pm    Onderwerp: update openoffice Reageren met citaat

Goedemiddag!

Is er een zoekfunctie op deze fora? Ik heb een probleem dat denk ik al wel eens behandeld is. Maar ik zie geen zoekmogelijkheid.
Het probleem is dat ik probeer OOo 1.1.1 onder FC2 te updaten naar 1.1.3-9.4.0, en vastloop in afhankelijkheden. Ik alleen de debuginfo-rpm succesvol installeren. Probeer ik de openoffice.org 1.1.3-rpm zelf, dan komt er een foutmelding dat ik lipspa645li.so, libvclplug_gen645li.so en openoffice.org-libs mis. Probeer ik eerst de update-rpm met OOo-libs te installeren, dan verwijst die terug naar de openoffice.org-rpm (dat die dus ontbreekt) en nota bene naar zichzelf.
Ik kan op het web een bespreking van een dergelijk probleem voor FC3 vinden, maar dat helpt me concreet niet veel verder (zie hieronder); weet iemand hoe je hier uit komt?

Re: reexecuting prelink

On Sun, Nov 21, 2004 at 12:13:29PM -0500, William Lovaton wrote:
> I just checked /var/log/prelink.log and I got this messages:
>
> /usr/sbin/prelink: /usr/lib/mozilla-1.7.3/libgtkembedmoz.so: Could not
> find one of the dependencies
...
> and this ones at the end:
>
> /usr/sbin/prelink: Could not
> prelink /usr/lib/ooo-1.1/program/libspa645li.so because its
> dependency /usr/lib/ooo-1.1/program/libvcl645li.so could not be
> prelinked
> /usr/sbin/prelink: Could not
> prelink /usr/lib/ooo-1.1/program/spadmin.bin because its
> dependency /usr/lib/ooo-1.1/program/libspa645li.so could not be
> prelinked
>
> It seems that there are some large programs, like openoffice, that are
> not able to take advantage of prelink. Is this ok? Are you seeing the
> same problems? Is there a solution?

It just means openoffice.org or firefox could not be prelinked.
The problem is that these programs use shared libraries stored in
paths that are not searched by ldconfig and lack DT_RPATH (usually
${ORIGIN} is good enough for these), so prelink is unable to find those
libraries. Usually these programs are started by wrapper scripts
that set LD_LIBRARY_PATH.
To make them prelinkable, either those dirs would need to be added
to ld.so.conf (usually by adding say /etc/ld.so.conf.d/openoffice.org.conf
or similar file to the rpm) or they would need to start using DT_RPATH,
or they'd need to move the libraries to paths that are searched by
ldconfig normally.

Jakub



En een andere reactie:


Re: reexecuting prelink

--------------------------

Hi,

I just checked /var/log/prelink.log and I got this messages:

/usr/sbin/prelink: /usr/lib/mozilla-1.7.3/libgtkembedmoz.so: Could not
find one of the dependencies
/usr/sbin/prelink: /usr/bin/devhelp-bin: Could not find one of the
dependencies
/usr/sbin/prelink: /usr/lib/ooo-1.1/program/libicuuc.so.22: Could not
find one of the dependencies
/usr/sbin/prelink: /usr/lib/ooo-1.1/program/libicule.so.22: Could not
find one of the dependencies
/usr/sbin/prelink: /usr/lib/firefox-0.10.1/xpcshell: Could not find one
and this ones at the end:

/usr/sbin/
/usr/sbin/prelink: Could not
prelink /usr/lib/ooo-1.1/program/spadmin.bin because its
dependency /usr/lib/ooo-1.1/program/libspa645li.so could not be
prelinked

It seems that there are some large programs, like openoffice, that are
not able to take advantage of prelink. Is this ok? Are you seeing the
same problems? Is there a solution?



-William



El sáb, 20-11-2004 a las 21:59 -0600, Satish Balay escribió:

> The prelink cron job runs once everyday - so you don't have to worry
> about running it manually.
>
> If you want to run this manually - run the script '/etc/cron.daily/prelink'
>
> Satish
Terug naar boven
Profiel bekijken Stuur privébericht
Coffeepad



Geregistreerd op: 25 Apr 2005
Berichten: 42

BerichtGeplaatst: Wo Sep 28, 2005 3:44 pm    Onderwerp: Reageren met citaat

Probeer je de boel handmatig te updaten ?

Prbeer het eens met Yum ,
open een terminal , type : su ( wachtwoord ) en vervolgen yum update
Terug naar boven
Profiel bekijken Stuur privébericht
jan



Geregistreerd op: 28 Sep 2005
Berichten: 8

BerichtGeplaatst: Wo Sep 28, 2005 9:46 pm    Onderwerp: Reageren met citaat

OK. Dank. Maar hoe vertel ik yum (of synaptic) om de rpm van het eigen systeem te halen (uit /home/jan/Tarballs_en_RPMs) en niet van de RedHat-site?
Ik kan in yum.conf de bron aanpassen, maar wat is precies de aanduiding van het eigen systeem? http://.....?

Jan
Terug naar boven
Profiel bekijken Stuur privébericht
kiemo



Geregistreerd op: 22 Aug 2005
Berichten: 203
Woonplaats: Amersfoort

BerichtGeplaatst: Do Sep 29, 2005 9:08 am    Onderwerp: Reageren met citaat

jan schreef:
OK. Dank. Maar hoe vertel ik yum (of synaptic) om de rpm van het eigen systeem te halen (uit /home/jan/Tarballs_en_RPMs) en niet van de RedHat-site?
Ik kan in yum.conf de bron aanpassen, maar wat is precies de aanduiding van het eigen systeem? http://.....?

Jan


yum localinstall bijvoorbeeld yum localinstall /home/jan/Tarballs_en_RPMs.
kijk maar eens bij $ man yum
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
jan



Geregistreerd op: 28 Sep 2005
Berichten: 8

BerichtGeplaatst: Do Sep 29, 2005 1:01 pm    Onderwerp: Reageren met citaat

Hmmm. Bij mij is het commando localinstall blijkbaar onbekend, want ik krijg dit:

[root@localhost jan]# yum <localinstall openoffice.org-1.1.3-9.4.0.fc3.i386.rpm /home/jan/Tarballs_en_RPMs
bash: localinstall: Onbekend bestand of map
[root@localhost jan]#

Is er een andere manier om de eigen schijf als bron in te stellen?

Het gaat trouwens niet om een install-, maar om een update actie. Maakt dat iets uit?

Jan
Terug naar boven
Profiel bekijken Stuur privébericht
kiemo



Geregistreerd op: 22 Aug 2005
Berichten: 203
Woonplaats: Amersfoort

BerichtGeplaatst: Do Sep 29, 2005 7:10 pm    Onderwerp: Reageren met citaat

jan schreef:
Hmmm. Bij mij is het commando localinstall blijkbaar onbekend,


Welke versie van yum gebruik je? En je hebt FC2, is het niet handig
om een upgrate te doen naar FC3 of FC4?
Terug naar boven
Profiel bekijken Stuur privébericht MSN Messenger
jan



Geregistreerd op: 28 Sep 2005
Berichten: 8

BerichtGeplaatst: Do Sep 29, 2005 9:35 pm    Onderwerp: Reageren met citaat

Ja, dat kan natuurlijk, maar ik wilde alleen maar OOo updaten. De rest van wat ik heb werkt goed, dus daar kom ik nu liever niet aan. Dit probleem van het installeren vanaf een locale schijf kan toch niet zo moeilijk zijn? Is Synaptic niet anders in te stellen?

Jan
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Installatie Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.