Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

VSFTPD icm passive modus

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Di Aug 26, 2008 6:40 pm    Onderwerp: VSFTPD icm passive modus Reageren met citaat

Hi,
ik heb VSFTPD draaien op mijn CentOS. Alles lijkt goed te staan, maar toch kan ik vanaf mijn PC niet naar de remote FTP server.

Ik krijg een PASSIVE MODE error.

Kan iemand helpen? Shocked Laughing


Laatst aangepast door hewavervelend op Vr Sep 26, 2008 5:50 pm; in totaal 1 keer bewerkt
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Di Aug 26, 2008 7:37 pm    Onderwerp: Reageren met citaat

Schakel bij wijze van test eens de firewall van de server even uit en probeer het dan nog eens. Lukt het dan?

Begrijp je waar deze instellingen voor zijn?
Code:
pasv_max_port=51000
pasv_min_port=50000
Terug naar boven
Profiel bekijken Stuur privébericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Wo Aug 27, 2008 6:05 am    Onderwerp: Reageren met citaat

Nickname55,
kun je me helpen hoe ik de firewall uitzet plus met de vraag omtrent de poorten? Confused Wink
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Wo Aug 27, 2008 12:16 pm    Onderwerp: Reageren met citaat

Heb je grafische omgeving? En welke versie van Fedora gebruik? Als je versie 9 gebruikt en je hebt grafische omgeving, kun je wellicht een knopje Firewall vinden of anders in een terminal als root intikken: system-config-firewall. Hier moet het wel lukken om firewall uit te zetten. Als je geen grafische omgeving hebt, tik je in: system-config-firewall-tui. Hiet moet je met tab-toets en spatie balk werken. Je ziet staan:
Code:
            ┌──────────────┤ Firewall-configuratie ├──────────────┐
            │                                                     │
            │ Een firewall beschermt tegen ongeautoriseerde       │
            │ netwerkinbreuken. Door een firewall aan te zetten   │
            │ worden alle binnenkomende connecties geblokkeerd.   │
            │ Door een firewall uit te zetten worden alle         │
            │ connecties toegelaten, wat niet aan te raden is.    │
            │                                                     │
            │               Firewall: [*] Aangezet                │
            │                                                     │
            │    ┌────┐      ┌───────────┐      ┌───────────┐     │
            │    │ OK │      │ Aanpassen │      │ Annuleren │     │
            │    └────┘      └───────────┘      └───────────┘     │
            │                                                     │
            │                                                     │
            └─────────────────────────────────────────────────────┘
Je navigeert met de tab toets je cursor op het sterretje, je drukt op de spatie balk en het sterretje is weg. Vervolgens druk je nog een paar keer op tab tot de cursor op de OK knop staat en je drukt weer op de spatie balk. Wink

Als je een oudere versies van Fedora gebruikt kan het zijn dat je system-config-firewall niet kunt vinden. Probeer dan system-config-securitylevel of system-config-securitylevel-tui. Dat tui staat voor Textbased User Interface.
Terug naar boven
Profiel bekijken Stuur privébericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Vr Sep 05, 2008 6:31 pm    Onderwerp: Reageren met citaat

Het probleem is verholpen, nadat de firewall is uitgezet.

Echter het volgende probleem ontstaat nu bij zowel inloggen middels gebruiker als anonymous.
De file kan niet worden geupload.

iemand een id?
Terug naar boven
Profiel bekijken Stuur privébericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Vr Sep 26, 2008 5:52 pm    Onderwerp: Reageren met citaat

Ik heb inmiddels de firewall weer aanstaan met daarbij alleen de vereiste poorten open.

Toch krijg ik een error als ik probeer in te loggen met een account.

Kan iemand helpen? Confused


#########################

WinSock 2.0
Connecting to FTP van de Veerdonk
Connected to x.y.q.z Port 21
220 (vsFTPd 2.0.5)
USER persoonlijk
530 Permission denied.
Connection failed
Delaying for 120 seconds before reconnect attempt #1
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Za Sep 27, 2008 9:57 pm    Onderwerp: Reageren met citaat

Heb je de gebruiker 'persoonlijk' toegevoegd? En hoe heb je dat gedaan?

Om nog even terug te komen op het eerdere: hoe heb je exact de poorten openen gezet? En het je diezelfde poorten ook ingesteld in het conf bestand met de pasv_max_port enpasv_min_port opties? en daarna vsftpd of pc herstart?
Terug naar boven
Profiel bekijken Stuur privébericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Wo Okt 01, 2008 4:33 pm    Onderwerp: Reageren met citaat

Ik heb de user persoonlijk toegevoegd via
# useradd -s/bin/shell -p******* -d/home/persoonlijk -m persoonlijk

Ik heb de firewall opengezet via system-config-securitylevel-tui In de GUI kan ik verschillende protocollen kiezen zoals FTP.

Als ik nu op mijn server ftp x.y.q.z doe, dan krijg ik het volgende

[root@creatable vsftpd]# ftp x.y.q.z
Connected to x.y.q.z.
220 Welcome! Rules are, you break it, you buy it.
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (x.y.q.z:root): persoonlijk
530 Permission denied.
Login failed.
ftp>

Voordat ik het password op kan geven krijg ik dus al een error.

Heeft iemand een id?
Terug naar boven
Profiel bekijken Stuur privébericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Wo Okt 01, 2008 4:44 pm    Onderwerp: Reageren met citaat

mijn vsftpd.conf ziet er momenteel zo uit:

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
ftpd_banner=Welcome! Rules are, you break it, you buy it.
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
pam_service_name=vsftpd
userlist_enable=YES
userlist_deny=NO
listen=YES
tcp_wrappers=YES
Terug naar boven
Profiel bekijken Stuur privébericht
hewavervelend



Geregistreerd op: 10 Jun 2005
Berichten: 26

BerichtGeplaatst: Wo Okt 01, 2008 5:03 pm    Onderwerp: Reageren met citaat

denk dat ik probleem gevonden heb.
Ik heb zojuist een andere user aangemaakt via;
useradd -d /home/user user
passwd user

en vervolgens 2x password.

Inloggen en uploaden gaat nu goed.
Lijkt erop dat ik de users niet goed aangemaakt heb.
Weet iemand hoe ik deze users kan verwijderen?
Terug naar boven
Profiel bekijken Stuur privébericht
Nickname55



Geregistreerd op: 02 Mei 2005
Berichten: 666

BerichtGeplaatst: Wo Okt 01, 2008 5:25 pm    Onderwerp: Reageren met citaat

hewavervelend schreef:
Ik heb de user persoonlijk toegevoegd via
# useradd -s/bin/shell -p******* -d/home/persoonlijk -m persoonlijk

Idd, dat met die parameter p en dan je passwoord hoort zo niet. Goed de manual lezen:
Citaat:
-p, --password PASSWORD
The encrypted password, as returned by crypt(3). The default is to
disable the account.
Er staat dus dat je het passwoord eerst door crypt heen moet halen, het resultaat daarvan daar neer zeten. Geen mens doet dat zo, men maakt altijd eerst de user aan met useradd en vervolgens met passwd het password setten.

Met userdel kan je gebruikers verwijderen. Dat werkt nogal simpel, gewoon
Code:
userdel <loginnaam>
Je kunt de parameter r meegeven, dan word ook de home dir verwijderd. Let op dat hier geen files instaan die je wilt houden.
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.