Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

vsftpd

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
jelmer_astra



Geregistreerd op: 04 Mrt 2007
Berichten: 5

BerichtGeplaatst: Vr Jan 25, 2008 9:13 pm    Onderwerp: vsftpd Reageren met citaat

Hallo mensen,

Ik heb nu een vsftp servertje lopen. Binnen me eigen netwerk werkt alles, maar zodra ik iemand vanaf buiten laat connecten krijgt hij de melding: 503 - Authencation failed. Ik heb poort 20 (tcp&udp) en 21 (tcp&udp) open in de router. We hebben het ook al geprobeerd over poort 1200, binnen me netwerk werkt dit maar vanaf buiten krijgen we precies dezelfde error.

Ik denk dat het in de firewall zit van de experia box maar durf het niet zeker te zeggen. Zijn er meer mensen die hier ervaring mee hebben? Ik ben morgen van plan om er een andere ftp server op te zetten en kijken als het dan wel werkt. Natuurlijk zijn andere oplossingen altijd welkom Wink

Alvast bedankt!

Groeten,

Jelmer Jansma
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Za Jan 26, 2008 10:57 am    Onderwerp: Reageren met citaat

Heb je die poorten ook open gezet in je server?

Je kunt er alleen van buiten niet op komen? Dus vanaf het internet? Is NAT enabled in je router?

Voor FTP hoef je alleen maar TCP open te zetten. UDP kun je weer dicht doen.
Terug naar boven
Profiel bekijken Stuur privébericht
jelmer_astra



Geregistreerd op: 04 Mrt 2007
Berichten: 5

BerichtGeplaatst: Za Jan 26, 2008 1:20 pm    Onderwerp: Reageren met citaat

Citaat:
Heb je die poorten ook open gezet in je server?


Ja heb alles open in me linux server

Citaat:
Je kunt er alleen van buiten niet op komen? Dus vanaf het internet? Is NAT enabled in je router?


Vanaf internet kan ik er inderdaad niet op komen. In de router is NAT enabled. Binnen me eigen netwerk kan ik er wel in komen. Het raare is dat er wel een verbinding word opgezet naar de server, dat is verder ook allemaal oké. Als hij het password wil controleren stopt hij ermee.
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Za Jan 26, 2008 3:05 pm    Onderwerp: Reageren met citaat

Welke Fedora versie staat geinstalleerd?

Ik heb hem op Fedora 7 draaien en bij mij is er niks aan de hand.

Heb je zelf nog wat zitten veranderen in de config file?
Terug naar boven
Profiel bekijken Stuur privébericht
jelmer_astra



Geregistreerd op: 04 Mrt 2007
Berichten: 5

BerichtGeplaatst: Za Jan 26, 2008 3:55 pm    Onderwerp: Reageren met citaat

fedora 8, ik heb verder helemaal niks ziten veranderen.
Terug naar boven
Profiel bekijken Stuur privébericht
Th3No0b



Geregistreerd op: 05 Jan 2006
Berichten: 502
Woonplaats: Emmeloord

BerichtGeplaatst: Vr Feb 08, 2008 10:25 am    Onderwerp: Reageren met citaat

Ik heb hetzelfde probleem.

Heb net een server geinstalleerd met Fedora 7 erop maar FTPd wil op geen enkele manier werken.

Ik heb vsftpd, proftp en pure-ftpd geprobeerd. Maar geen een wou werken.

Heb poort 21 open staan naar server en op server ook 21 open gezet. De user heeft gewoon auth om erop te komen en in zijn eige map rond te dwalen. Hij komt hier echter niet.

vsftpd zecht helemaal niks, wil gewoon in loggen.
pure-ftpd kan de home map niet openen.
proftpd heeft hetzelfde als pure-ftpd.

Het rare, Anymous werkt wel (bij vsftpd, en pure-ftpd).


Heb config bestanden bekeken en hier staat niks raars in. Ik heb het nog niet vanuit LAN geprobeerd, alleen vanaf internet.

Volgens mij heeft de server geen bevoegdheid om in de users map te komen ofzo. Geen root rechten ofzo.

Hebben meer mensen hier last van op Fedora 8? Fedora 7 was alles nog goed maar 8 doet echt verschikkelijk raar. Kan nix beginnen met een server zonder FTP Razz

Edit \

Ik connect naar localhost met yafc, output is dit:

Code:
Trying GSSAPI...
Please login with USER and PASS.
The server doesn't support the FTP security extensions.
*** Using plaintext username and password ***
OOPS: cannot change directory:/home/XXXX
Sleeping 30 seconds before connecting again (attempt #2)...


Edit \ Edit (de laatste Razz)

Heb hem aan de praat! Very Happy

Code:
"man ftpd_selinux" says:

SELinux ftp daemon policy is customizable based on least access
required. So by default SElinux does not allow users to login and
read their home directories. If you are setting up this machine as
a ftpd server and wish to allow users to access their home
directorories, you need to set the ftp_home_dir boolean.

setsebool -P ftp_home_dir 1


SELinux staat aan! Hoe zet ik dat uit? Heb nu in SELinux enabled dat chroot dir gelezen mag worden maar wil hem graag uit hebben. Ben er niet gewent mee te werken en aangezien het geen grote server is... Razz

Edit \ Edit \ Edit

SELinux uitgezet en nu werkt alles weer zoals het hoort! Razz Security zal wel wat lager staan maar daar heb ik geen problemen mee.

Oplossing:
Code:
cd /etc/selinux
vi config

Hier kun je SELinux uit zetten!
Terug naar boven
Profiel bekijken Stuur privébericht
wvsutphen



Geregistreerd op: 28 Feb 2006
Berichten: 3

BerichtGeplaatst: Za Apr 26, 2008 9:11 am    Onderwerp: Reageren met citaat

Hoi Jelmer-astra,


Ik loop ook tegen dit probleem aan. Ik heb al vaker Fedora geinstalleerd op mijn PC-tje en telkens
krijg ik vsftpd niet (goed) aan de praat.
WIKI gevolgd, forums gelezen, andere FTP proggies geprobeerd maar dezelfde problemen. Confused

Intussen heb ik (denk ik) de oplossing gevonden.

Volg gewoon de WIKI en configureer zoals jij vsftpd wilt hebben.
Daarna verwijder vsftpd en instaleer opnieuw. je hoeft je config niet eens opnieuw te veranderen.

yum remove vsftpd
yum install vsftpd

en bij mij werkt deze truuk altijd. Very Happy

Succes.

Willem
Terug naar boven
Profiel bekijken Stuur privébericht
Michel F



Geregistreerd op: 07 Mrt 2008
Berichten: 6
Woonplaats: Enschede

BerichtGeplaatst: Do Mei 01, 2008 8:11 pm    Onderwerp: Reageren met citaat

probeer t is met selinux uitgeschakeld (al dan niet tijdelijk)
vaak zit t probleem hierin.
Terug naar boven
Profiel bekijken Stuur privébericht Website bekijken
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.