Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

samba met authentificatie werkt niet / niet goed

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
gerwin



Geregistreerd op: 07 Feb 2007
Berichten: 1

BerichtGeplaatst: Wo Feb 07, 2007 11:21 am    Onderwerp: samba met authentificatie werkt niet / niet goed Reageren met citaat

Voor school moet ik een server met samba opzetten nu heb ik daar het volgende probleem mee.

Ik heb 4 groepen met elk 2 users de users mogen alleen de map zien van hun groep dus niet van andere wat nu wel gebeurt.

Ik heb ook alle mappen ingesteld voor de juiste rechten maar ik kan niks uploaden in de prive map maar ik kan wel uploaden in de publiek share en in de groep map maar ik kan ook uplaoden in de mappen van andere groepen wat niet hoort.

smb.conf



Code:

# /etc/samba/smb.conf met authentificatie

[global]
workgroup = MCN.alfa
netbios name = MCN
server string = LAN bestands-server
domain master = yes
os level = 64
preferred master = yes
domain logons = yes
logon script = yes
log file = /var/log/samba/log
log level = 2
max log size = 50

#[netlogon]
#comment = Network Logon Service
#path = /var/samba/netlogon
#guest ok = yes
#browseable = no

[homes]
comment = Userīs Home Directories
valid users = %s
browseable = no
read only = no

[share-data]
comment = Data Directory
path = /share-data
read only = no

[administratie]
comment = Data Directory
path = /home/administratie
valid user = @administratie
read only = no

[verpleging]
comment = Data Directory
path = /home/verpleging
valid user = @verpleging
read only = no

[artsen]
comment = Data Directory
path = /home/artsen
valid user = @artsen
read only = no

[facilitaire-dienst]
comment = Data Directory
path = /home/facilitaire-dienst
valid user = @facilitaire-dienst
read only = no


[patienten]
comment = Data Directory
path = /home/patienten
valid user = @patienten
read only = no


En de rechten van de mappen.

Code:

[root@localhost home]# ls -li
totaal 60
391538 drwxrwxrwx  2 root                 administratie      4096 feb  7 10:57 administratie
410425 drwx-----T  4 administratie_1      administratie      4096 feb  7 10:51 administratie_1
410437 drwx-----T  4 administratie_2      administratie      4096 feb  7 10:52 administratie_2
391377 drwxrwxrwx  2 root                 artsen             4096 feb  7 10:57 artsen
410449 drwxrwx--T  4 artsen_1             artsen             4096 feb  7 10:52 artsen_1
410461 drwx-----T  4 artsen_2             artsen             4096 feb  7 10:52 artsen_2
396837 drwxrwxrwx  2 root                 facilitaire-dienst 4096 feb  7 10:57 facilitaire-dienst
397168 drwx-----T  4 facilitaire-dienst_1 facilitaire-dienst 4096 feb  7 10:49 facilitaire-dienst_1
397180 drwx-----T  4 facilitaire-dienst_2 facilitaire-dienst 4096 feb  7 10:49 facilitaire-dienst_2
396847 drwx-----T  4 patienten_1          patienten          4096 feb  7 10:50 patienen_1
396838 drwxrwxrwx  2 root                 patienten          4096 feb  7 10:57 patienten
410413 drwx-----T  4 patienten_2          patienten          4096 feb  7 10:51 patienten_2
397140 drwxrwxrwx  2 verpleging_1         verpleging         4096 feb  7 10:47 verpleging
397128 drwxrwxrwt  4 verpleging_1         patienten          4096 feb  6 12:20 verpleging_1
397192 drwx-----T  4 verpleging_2         verpleging         4096 feb  7 10:50 verpleging_2
[root@localhost home]


Wat o wat doe ik fout ? met tail -f /var/log/messages geeft hij geen fouten maar zodra ik dus iets copier vanaf een windows bak dan gaat alles fout. ik gebruik fedora core 4
Terug naar boven
Profiel bekijken Stuur privébericht
zoekend



Geregistreerd op: 17 Jan 2006
Berichten: 68
Woonplaats: NL

BerichtGeplaatst: Wo Feb 14, 2007 11:06 am    Onderwerp: Reageren met citaat

Hoi,
Heb je wel de allerlaatste samba updates erop staan?
Laatse versie is versie 3.0.21
Even yum update samba doen vanuit de console.

Misschien heeft het niets met jouw probleem te maken maar een laatste release draaien kan veel problemen sowieso verhelpen.
Terug naar boven
Profiel bekijken Stuur privébericht
Beer



Geregistreerd op: 17 Feb 2005
Berichten: 473

BerichtGeplaatst: Wo Feb 14, 2007 11:38 am    Onderwerp: Reageren met citaat

Domme vraag van mijn kant:
Configuratie en .conf-file wel opnieuw geladen voor je het een en ander ging testen?.
Terug naar boven
Profiel bekijken Stuur privébericht
jabs



Geregistreerd op: 30 Dec 2006
Berichten: 4
Woonplaats: Zeeuws-vlaanderen

BerichtGeplaatst: Wo Mrt 21, 2007 9:59 pm    Onderwerp: Reageren met citaat

Volgens mij moet dat wel kunnen. Ik weet niet precies je oplossing
maar zet bij elke map eens printable=no
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.