Fedora-Linux.nl Forumindex Fedora-Linux.nl
Het forum van Fedora-Linux.nl.
Deze site wordt gehost door Exonet Internet Services
 
 FAQFAQ   ZoekenZoeken   GebruikerslijstGebruikerslijst   GebruikersgroepenGebruikersgroepen   RegistrerenRegistreren 
 ProfielProfiel   Log in om je privéberichten te bekijkenLog in om je privéberichten te bekijken   InloggenInloggen 

PLESK probleem bij upgrade PHP 5

 
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken
Vorige onderwerp :: Volgende onderwerp  
Auteur Bericht
Geoffrey



Geregistreerd op: 08 Mrt 2006
Berichten: 34
Woonplaats: Waregem

BerichtGeplaatst: Do Sep 14, 2006 10:21 am    Onderwerp: PLESK probleem bij upgrade PHP 5 Reageren met citaat

Beste,

Ik huur een VPS met FC2, PLESK 7.5.4 en MySQL 4.21 erop geïnstalleerd.

Ik heb de versie van PHP geupgrade naar PHP 5 op deze manier:

1) yum remove php
(er werden ook een heleboel psa packages verwijderd...)

2) yum install php

Mijn websites werken, maar psa wil niet meer opstarten...
(http://87.233.130.225/php.php)


3) yum remove psa

4) yum install psa

5) yum install psa-*

(Note: ik heb de ART repo gebruikt hiervoor)

Output rpm -qa | grep php:
Code:
[root@gbeulque root]# rpm -qa | grep php
php-5.0.4-13.rhfc2.art
php-odbc-5.0.4-13.rhfc2.art
php-imap-5.0.4-13.rhfc2.art
php-pgsql-5.0.4-13.rhfc2.art
php-gd-5.0.4-13.rhfc2.art
php-devel-5.0.4-13.rhfc2.art
php-snmp-5.0.4-13.rhfc2.art
php-xml-5.0.4-13.rhfc2.art
php-ldap-5.0.4-13.rhfc2.art
php-pear-5.0.4-13.rhfc2.art
php-mysql-5.0.4-13.rhfc2.art
php-mbstring-5.0.4-13.rhfc2.art


Output rpm -qa | grep psa:
Code:
[root@gbeulque root]# rpm -qa | grep psa
perl-FreezeThaw-0.43-61psa
psa-logrotate-3.7-fc2.build75050824.12
psa-api-rpc-protocol-7.5.4-fc2.build75050930.11
psa-hotfix3-7.5.4-fc2.build75051115.01
psa-sbm2-1.0-49
psa-ingo-1.0.1-fc2.build75050824.12
psa-vpn-1.0.0-fc2.build75050824.12
psa-horde-3.0.5-fc2.build75050824.12
psa-manual-custom-skin-guide-7.5.4-fc2.build75050824.12
perl-HTML-Format-1.23-51psa
psa-bu-7.5.4-fc2.build75050926.17
psa-hotfix5-7.5.4-fc2.build75060118.18
psa-hotfix-7.5.4-fc2.build75050926.17
perl-MLDBM-2.01-61psa
psa-proftpd-1.2.10-fc2.build75050824.12
psa-boost-1.32.0-6
psa-autoinstaller-2.0.0-fc2.build75050906.11
psa-api-common-7.5.4-fc2.build75051014.16
psa-hotfix2-7.5.4-fc2.build75051014.16
psa-kronolith-2.0.3-fc2.build75050824.12
psa-tomcat-configurator-7.5.4-fc2.build75050824.12
psa-api-rpc-doc-7.5.4-fc2.build75050930.11
perl-MLDBM-Sync-0.30-61psa
psa-proftpd-xinetd-1.2.10-fc2.build75050824.12
perl-Font-AFM-1.18-61psa
psa-turba-2.0.3-fc2.build75050926.17
psa-fileserver-1.0.0-fc2.build75050824.12
psa-api-rpc-7.5.4-fc2.build75050930.11
psa-key-7.5-fc2.build75050824.12
psa-qmail-1.03-fc2.build75050824.12
psa-api-cli-7.5.4-fc2.build75051014.16
psa-hotfix4-7.5.4-fc2.build75051209.14
psa-firewall-1.0.1-fc2.build75050824.12
psa-bf1942-1.0.0-fc2.build75050824.12
psa-pre-keyupdate-7.5.4-fc2.build75050824.12
psa-courier-imap-add-7.5.4-fc2.build75050902.17
psa-7.5.4-fc2.build75050824.12
psa-locale-base-en-US-7.5.4-fc2.build75051115.01
psa-imp-4.0.3-fc2.build75050824.12
psa-migration-manager-7.5.4-fc2.build75050930.11
psa-qmail-rblsmtpd-0.70-fc2.build75050824.12
psa-spamassassin-7.5.4-fc2.build75060118.18
psa-sbm-1.1-35
psa-mnemo-2.0.1-fc2.build75050824.12
psa-agent-1.3.5-75050930.11
psa-passwd-3.0-fc2.build75050824.12
psa-watchdog-1.0.0-fc2.build75050926.17


Kan iemand me a.u.b. wat verder helpen met het oplossen van dit probleem?

Alavast héél hartelijk bedankt!!! Cool

Met vriendelijke groet,

Geoffrey
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Do Sep 14, 2006 12:16 pm    Onderwerp: Re: PLESK probleem bij upgrade PHP 5 Reageren met citaat

Geoffrey schreef:
Beste,

Ik huur een VPS met FC2, PLESK 7.5.4 en MySQL 4.21 erop geïnstalleerd.

Ik heb de versie van PHP geupgrade naar PHP 5 op deze manier:

1) yum remove php
(er werden ook een heleboel psa packages verwijderd...)

2) yum install php
(Note: ik heb de ART repo gebruikt hiervoor)

Mijn websites werken, maar psa wil niet meer opstarten...


Waarom mix je een vage upgrade repository met een pakket wat misschien wel afhankelijkheden heeft op PHP4? Niet alle PHP code werkt automatisch goed op PHP5 en waarschijnlijk heeft jouw Plesk console daar last van. Het lijkt me geen slecht idee om voor je packages van je server gaat slopen te checken of zo'n upgrade enigszins gaat werken.

De eenvoudigste oplossing die ik kan bedenken is het terugzetten van PHP4...
Terug naar boven
Profiel bekijken Stuur privébericht
Geoffrey



Geregistreerd op: 08 Mrt 2006
Berichten: 34
Woonplaats: Waregem

BerichtGeplaatst: Do Sep 14, 2006 12:20 pm    Onderwerp: Reageren met citaat

Bedankt voor je reactie!!

Er is idd 1 dependency voor psa die php 4.3 vereist, en dat is php-domxml...

Is het niet mogelijk om PHP 4 en PHP 5 naast elkaar te installeren op de server?

Ik heb al geprobeerd om de RPM van PHP 4 te installeren, maar dan krijg ik volgende foutmelding:

Code:
[root@gbeulque RPMS]# rpm -ivh php-4.3.4-11.i386.rpm
/etc/security/selinux/file_contexts: No such file or directory
warning: php-4.3.4-11.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing...                ########################################### [100%]
        package php-5.0.4-13.rhfc2.art (which is newer than php-4.3.4-11) is already installed
        file /etc/httpd/conf.d/php.conf from install of php-4.3.4-11 conflicts with file from package php-5.0.4-13.rhfc2.art
        file /etc/pear.conf from install of php-4.3.4-11 conflicts with file from package php-5.0.4-13.rhfc2.art
        file /etc/php.ini from install of php-4.3.4-11 conflicts with file from package php-5.0.4-13.rhfc2.art
        file /usr/bin/php from install of php-4.3.4-11 conflicts with file from package php-5.0.4-13.rhfc2.art


Bedankt!
Terug naar boven
Profiel bekijken Stuur privébericht E-mail versturen Website bekijken
klaasjan



Geregistreerd op: 22 Dec 2005
Berichten: 868

BerichtGeplaatst: Do Sep 14, 2006 12:41 pm    Onderwerp: Reageren met citaat

Geoffrey schreef:
Bedankt voor je reactie!!

Er is idd 1 dependency voor psa die php 4.3 vereist, en dat is php-domxml...

Is het niet mogelijk om PHP 4 en PHP 5 naast elkaar te installeren op de server?

Jawel, maar het schijnt dat ze niet als module draaien in dezelfde Apache, dus je zal tenminste 1 PHP via fastcgi moeten draaien. Of 2 Apache servers met de PHP module waarvan 1 op poort 80 de verzoeken voor de andere via mod_proxy doorgeeft. Je zal je wel eerst goed moeten verdiepen in Apache om dat aan de gang te krijgen.

Citaat:

Ik heb al geprobeerd om de RPM van PHP 4 te installeren, maar dan krijg ik volgende foutmelding:

Dat is een packaging probleem omdat beide packages er vanuit gaan dat er maar 1 PHP installatie op je systeem komt. Je kan PHP5 zelf van source bouwen (dat moet toch wel als je afwijkt van de standaard configuratie) en de module naast de PHP4 installatie zetten.
Terug naar boven
Profiel bekijken Stuur privébericht
Berichten van afgelopen:   
Nieuw onderwerp plaatsen   Reageren    Fedora-Linux.nl Forumindex -> Servers & Netwerken Tijden zijn in GMT + 1 uur
Pagina 1 van 1

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen in dit subforum
Je mag geen reacties plaatsen in dit subforum
Je mag je berichten niet bewerken in dit subforum
Je mag je berichten niet verwijderen in dit subforum
Je mag niet stemmen in polls in dit subforum


Powered by phpBB © 2001, 2005 phpBB Group
Vertaling door Lennart Goosens.